Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th February 2007, 10:24
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default http://www.domain.com/ shows login.php instead of index file

Why do my hosted domains redirect automatically to:

http://www.domain.com/login.php

Instead of displaying their default index.html files that are intact?!?

Does anyone know why this is happening?
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2007, 11:27
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

this is very very frustrating... i am very busy this week and i have wasted many hours on this software...

i installed on a clean boot of CentOS & followed the "perfect setup" instructions exactly but the system does not work...

why do my domains not show the files in their FTP directories? instead they just ask the user to login!?!!
Reply With Quote
  #3  
Old 27th February 2007, 11:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

ISPConfig has no login.php files in the websites. So thats a problem which is not ISPConfig related.

You should have a look if there is a .htaccess file in the directory that does some kind of redirect or if your index.html file contains a redirect.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 27th February 2007, 11:47
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It definitely is related!!

Everything appears to be set up properly in the .conf files...

However, it redirects to:

/home/admispconfig/ispconfig/web/login.php

I edited the title in the login.php like this:

Quote:
[root@matthew web]# locate login.php
/home/admispconfig/ispconfig/web/login/trylogin.php
/home/admispconfig/ispconfig/web/login/login.php
/home/admispconfig/ispconfig/web/login.php
[root@matthew web]# vi /home/admispconfig/ispconfig/web/login.php
[root@matthew web]#
And changed the title line:

Quote:
<title>ISPConfig - Login - Boo</title>
Here is the hosting directory:

Quote:
[root@matthew web]# cd /var/www/web2/web/
[root@matthew web]# ls -all
total 40
drwxrwxr-x 4 web2_matt web2 4096 Feb 27 04:40 .
drwxr-xr-x 9 web2_matt web2 4096 Feb 27 04:25 ..
drwxrwxr-x 2 web2_matt web2 4096 Feb 26 04:10 error
-rw-rw-r-- 1 web2_matt web2 1213 Feb 27 04:25 index.html
drwxr-xr-x 2 web2_matt web2 4096 Feb 27 04:00 stats
[root@matthew web]#

Last edited by mtoom; 27th February 2007 at 13:52.
Reply With Quote
  #5  
Old 27th February 2007, 11:50
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think somehow, the server is set up to have login on BOTH http at port 80 and https at port 81... is that possible? Right now I only have one domain directed to this server...

If I manually start httpd, after shutting off ispconfig, the hosting account behaves differently and I can view index.html

I have no idea why.
Reply With Quote
  #6  
Old 27th February 2007, 11:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

I guess you mix up websites and the ISPConfig controlpanel.

If you connect to your server on port 80 it can not redirect to /home/admispconfig/ispconfig/web/login/trylogin.php because that server is listening on port 81. Check your router if you forward port 80 to 81 accidently!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 27th February 2007, 12:08
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can log in and use the ispconfig control panel for either my http or https...


HOWEVER

If I do this:

Quote:
[root@matthew web]# ps aux | grep httpd
root 983 0.0 1.7 17024 8680 ? Ss 04:58 0:00 /root/ispconfig/h ttpd/bin/ispconfig_httpd -DSSL
102 997 0.0 1.7 17168 8652 ? S 04:58 0:00 /root/ispconfig/h ttpd/bin/ispconfig_httpd -DSSL
102 1119 0.0 1.7 17172 8536 ? S 04:59 0:00 /root/ispconfig/h ttpd/bin/ispconfig_httpd -DSSL
root 1224 0.0 0.0 1396 140 pts/1 R+ 05:04 0:00 grep httpd
[root@matthew web]# killall ispconfig_httpd
[root@matthew web]# ps aux | grep httpd
root 1236 0.0 0.1 3936 640 pts/1 S+ 05:04 0:00 grep httpd
[root@matthew web]# httpd -e DEBUG
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module access_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module auth_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module auth_anon_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module auth_dbm_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module auth_digest_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module ldap_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module auth_ldap_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module include_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module log_config_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module env_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module mime_magic_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module cern_meta_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module expires_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module deflate_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module headers_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module usertrack_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module setenvif_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module mime_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module dav_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module status_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module autoindex_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module asis_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module info_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module dav_fs_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module vhost_alias_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module negotiation_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module dir_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module imap_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module actions_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module speling_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module userdir_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module alias_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module rewrite_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module proxy_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module proxy_ftp_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module proxy_http_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module proxy_connect_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module cache_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module suexec_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module disk_cache_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module file_cache_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module mem_cache_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module cgi_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module perl_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module php4_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module python_module
[Tue Feb 27 05:04:50 2007] [debug] mod_so.c(247): loaded module ssl_module
[root@matthew web]#
[root@matthew web]# netstat -e -a -l -T -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State User Inode PID/Program name
tcp 0 0 *:mysql *:* LISTEN root 6848 3150/mysqld
tcp 0 0 *:sunrpc *:* LISTEN root 6282 2852/portmap
tcp 0 0 matthew.theplanet.host:http *:* LISTEN root 154953 1576/httpd
tcp 0 0 e2.dc.344a.static.theplanet.com:http *:* LISTEN root 154955 1576/httpd
tcp 0 0 e6.dc.344a.static.theplanet.com:domain *:* LISTEN named 154545 1509/named
tcp 0 0 e5.dc.344a.static.theplanet.com:domain *:* LISTEN named 154543 1509/named
tcp 0 0 e4.dc.344a.static.theplanet.com:domain *:* LISTEN named 154541 1509/named
tcp 0 0 e3.dc.344a.static.theplanet.com:domain *:* LISTEN named 154539 1509/named
tcp 0 0 e2.dc.344a.static.theplanet.com:domain *:* LISTEN named 154537 1509/named
tcp 0 0 matthew.theplanet.host:domain *:* LISTEN named 154535 1509/named
tcp 0 0 *:ipp *:* LISTEN root 6631 2986/cupsd
tcp 0 0 matthew.theplanet.host:rndc *:* LISTEN named 154548 1509/named
tcp 0 0 *:smtp *:* LISTEN root 154339 1483/master
tcp 0 0 *:imaps *:* LISTEN root 6881 3173/dovecot
tcp 0 0 *op3s *:* LISTEN root 6883 3173/dovecot
tcp 0 0 *op3 *:* LISTEN root 6882 3173/dovecot
tcp 0 0 *:imap *:* LISTEN root 6880 3173/dovecot
tcp 0 0 *:ftp *:* LISTEN nobody 154586 1527/proftpd: (acce
tcp 0 0 *:ssh *:* LISTEN root 6656 3031/sshd
tcp 0 0 *:https *:* LISTEN root 154958 1576/httpd
tcp 0 4560 e2.dc.344a.static.theplanet.com:ssh cust-65-110-31-90.sfu-reznet.connectwest.net:61004 ESTABLISHED root 139683 28069/1
[root@matthew web]#
NOW:

the http hosting works properly, but https

Does NOT respond.

Last edited by mtoom; 27th February 2007 at 13:52.
Reply With Quote
  #8  
Old 27th February 2007, 12:10
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
[root@matthew web]# killall httpd
[root@matthew web]# /etc/rc.d/init.d/ispconfig_server restart
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
[root@matthew web]#
[root@matthew web]# netstat -e -a -l -T -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State User Inode PID/Program name
tcp 0 0 *:mysql *:* LISTEN root 6848 3150/mysqld
tcp 0 0 *:sunrpc *:* LISTEN root 6282 2852/portmap
tcp 0 0 matthew.theplanet.host:http *:* LISTEN root 154105 1398/ispconfig_http
tcp 0 0 e2.dc.344a.static.theplanet.com:http *:* LISTEN root 154104 1398/ispconfig_http
tcp 0 0 *:81 *:* LISTEN root 154103 1398/ispconfig_http
tcp 0 0 e6.dc.344a.static.theplanet.com:domain *:* LISTEN named 154545 1509/named
tcp 0 0 e5.dc.344a.static.theplanet.com:domain *:* LISTEN named 154543 1509/named
tcp 0 0 e4.dc.344a.static.theplanet.com:domain *:* LISTEN named 154541 1509/named
tcp 0 0 e3.dc.344a.static.theplanet.com:domain *:* LISTEN named 154539 1509/named
tcp 0 0 e2.dc.344a.static.theplanet.com:domain *:* LISTEN named 154537 1509/named
tcp 0 0 matthew.theplanet.host:domain *:* LISTEN named 154535 1509/named
tcp 0 0 *:ipp *:* LISTEN root 6631 2986/cupsd
tcp 0 0 matthew.theplanet.host:rndc *:* LISTEN named 154548 1509/named
tcp 0 0 *:smtp *:* LISTEN root 154339 1483/master
tcp 0 0 *:imaps *:* LISTEN root 6881 3173/dovecot
tcp 0 0 *op3s *:* LISTEN root 6883 3173/dovecot
tcp 0 0 *op3 *:* LISTEN root 6882 3173/dovecot
tcp 0 0 *:imap *:* LISTEN root 6880 3173/dovecot
tcp 0 0 *:ftp *:* LISTEN nobody 154586 1527/proftpd: (acce
tcp 0 0 *:ssh *:* LISTEN root 6656 3031/sshd
tcp 0 4792 e2.dc.344a.static.theplanet.com:ssh cust-65-110-31-90.sfu-reznet.connectwest.net:61004 ESTABLISHED root 139683 28069/1
[root@matthew web]#
Now, once again, http gives the same result as: https:81

You think that is a port forwarding issue? I was pretty sure it was related to ISPconfig http.conf settings somehow...?

Last edited by mtoom; 27th February 2007 at 13:53.
Reply With Quote
  #9  
Old 27th February 2007, 12:17
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
ISPConfig has no login.php files in the websites. So thats a problem which is not ISPConfig related.

You should have a look if there is a .htaccess file in the directory that does some kind of redirect or if your index.html file contains a redirect.
There is no .htaccess

The installation is on a virgin CentOS system & I have not added a .htaccess file to the dir.

Quote:
[root@matthew web]# ls -all
total 40
drwxrwxr-x 4 web2_matt web2 4096 Feb 27 04:40 .
drwxr-xr-x 9 web2_matt web2 4096 Feb 27 04:25 ..
drwxrwxr-x 2 web2_matt web2 4096 Feb 26 04:10 error
-rw-rw-r-- 1 web2_matt web2 1213 Feb 27 04:25 index.html
drwxr-xr-x 2 web2_matt web2 4096 Feb 27 04:00 stats
[root@matthew web]# rm .htaccess
rm: cannot lstat `.htaccess': No such file or directory
[root@matthew web]#
There is NO redirect... the index.html is exactly as created by ISPconfig:

Quote:
<HTML>
<HEAD>
<TITLE>Welcome!</TITLE>
</HEAD>
<BODY BGCOLOR="#FFFFFF" leftMargin=0 topMargin=0 rightMargin=0 marginheight="0" marginwidth="0">
<CENTER>
<TABLE BORDER="0" WIDTH="100%" CELLSPACING="0">
<TR>
<TD BGCOLOR="#025CCA" ALIGN="CENTER">
<HR SIZE="1" COLOR="#FFFFFF">
<TABLE>
<TR>
<TD><FONT SIZE="3" COLOR="#FFFFFF" FACE="Helvetica, Arial"><B>Welcome
to
<!--ADRESSE//-->www.domain.com!<!--ADRESSE//-->
</B></FONT></TD>
</TR>
</TABLE>
<HR SIZE="1" COLOR="#FFFFFF">
</TD>
</TR>
<TR>
<TD BGCOLOR="#FFFFFF">
<BR><BR><CENTER>
<FONT COLOR="#000000" SIZE="2" FACE="Helvetica, Arial">This is the standard index of your website. You can easily delete it or replace it with another file. This is the index.html file
in the <B>web</B> directory.
<P>For questions or problems please contact the server administrator.</FONT> </CENTER>
<BR>

<HR SIZE="1" WIDTH="90%">
<CENTER>
<FONT SIZE="1" COLOR="#000000" FACE="Verdana, Arial">powered by <A HREF="http://www.ispconfig.org">ISPConfig</A></FONT>
</CENTER>
</TD>
</TR>
</TABLE>
</CENTER>
</BODY>
</HTML>

Last edited by mtoom; 27th February 2007 at 13:54.
Reply With Quote
  #10  
Old 27th February 2007, 12:23
mtoom mtoom is offline
Junior Member
 
Join Date: Feb 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

AHHHH!!!!!!!!!!

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dspam planet_fox General 6 20th January 2007 18:42
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 16:12
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 04:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.