#1  
Old 16th February 2007, 19:19
raye raye is offline
Guest
 
Join Date: Feb 2007
Location: United States
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default SpamAssassin

Hello and good day. I am trying to install the Spam AV gateway on my Fedora Core 5 Linux machine. I am using the how to as per the website http://www.howtoforge.com/linux_spam...r_mail_gateway but I am having a problem with the actual spamassassin install using the command line "perl -MCPAN -e 'install Mail::SpamAssassin". I simply get a > prompt after issuing the command. Am I missing something?

Also, I was reading the user posts at the bottom of the website and someone mentioned MailScanner and Postfix not being completely compatible. How true is this? Are there versions that are more compatible with one another? If so, which ones? I could simply install those compatible versions and not working about upgrading since we just need the spam av features and nothing more. Thanks!

Ray
Reply With Quote
Sponsored Links
  #2  
Old 16th February 2007, 20:12
raye raye is offline
Guest
 
Join Date: Feb 2007
Location: United States
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default solved

Quote:
Originally Posted by raye
Hello and good day. I am trying to install the Spam AV gateway on my Fedora Core 5 Linux machine. I am using the how to as per the website http://www.howtoforge.com/linux_spam...r_mail_gateway but I am having a problem with the actual spamassassin install using the command line "perl -MCPAN -e 'install Mail::SpamAssassin". I simply get a > prompt after issuing the command. Am I missing something?

Also, I was reading the user posts at the bottom of the website and someone mentioned MailScanner and Postfix not being completely compatible. How true is this? Are there versions that are more compatible with one another? If so, which ones? I could simply install those compatible versions and not working about upgrading since we just need the spam av features and nothing more. Thanks!

Ray
Figured it out there is a ' missing at the end of the command.

perl -MCPAN -e 'install Mail::SpamAssassin' <==== Might wanna fix that on the website.

Now the problem I am having is this: I chose the default configuration for the install but it gave me a bunch of error's. I am behind a proxy so I think it had problems connecting to the CPAN sites to acquire the necessary info. What can I do? I tried deleting the directory and re installing spamassassin but it will not allow me to do a manual config as before. Help!

Ray
Reply With Quote
  #3  
Old 17th February 2007, 17:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

If you have Webmin installed you can use that to install Perl modules (such as SpamAssassin). Maybe it works better than the Perl shell in your situation.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 20th February 2007, 16:56
raye raye is offline
Guest
 
Join Date: Feb 2007
Location: United States
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default webadmin

Quote:
Originally Posted by falko
If you have Webmin installed you can use that to install Perl modules (such as SpamAssassin). Maybe it works better than the Perl shell in your situation.
We have a proxy setup and I can't use the port that the webadmin needs. I also can do yum updates for the same reason. Is there a way to configure either for open http ports?
Reply With Quote
  #5  
Old 21st February 2007, 23:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

I'm not sure how to use webmin/yum with a proxy...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question on Clamscan and SpamAssassin AZMel Installation/Configuration 3 11th January 2007 19:56
Spamassassin being over protective bluethunder82 General 17 5th December 2006 17:47
SpamAssassin (lugin) with Munin edge Server Operation 4 18th August 2006 23:37
config spamassassin hotchilli Server Operation 1 8th July 2006 12:03
Postfix + Amavis + SpamAssassin + ClamAV michele HOWTO-Related Questions 4 1st July 2006 14:36


All times are GMT +2. The time now is 00:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.