Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 1st February 2007, 10:29
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
Exclamation NameVirtualHost www.mysite.it has no VirtualHosts

I have 3 virtualhosts on an apache2 running on a debian 2.6.8 stable . I don't understand why the site still being reachable , when i restart apache2 , it shows this error:
Code:
root@www:~# /etc/init.d/apache2 restart
Forcing reload of web server: Apache2[Thu Feb 01 10:13:45 2007] [warn] NameVirtualHost x.gabrix.ath.cx:0 has no VirtualHosts
[Thu Feb 01 10:13:45 2007] [warn] NameVirtualHost x.gabrix.ath.cx:0 has no VirtualHosts
It happens only for the site above , and all sites have same virtualhost in pache2.conf and dir /etc/apache2/sites-enabled here the apache2.conf:
Code:
<VirtualHost tor.gabrix.ath.cx>
     ServerName tor.gabrix.ath.cx
     ServerAlias tor.gabrix.cx
     ServerAdmin gabrix@gabrix.ath.cx
     DocumentRoot /var/www/torgab
     ErrorLog /var/log/apache2/tor_error.log
     TransferLog /var/log/apache2/tor_access.log
<IfModule mod_security.c>
     CustomLog /var/log/apache2/tor_modsec_custom_log \
        "%h %l %u %t \"%r\" %>s %b %{mod_security-message}i" \
        env=mod_security-relevant
</IfModule>
</VirtualHost>

<VirtualHost www.gabrix.ath.cx>
     ServerName www.gabrix.ath.cx
     ServerAlias www.gabrix.cx
     ServerAdmin gabrix@gabrix.ath.cx
     DocumentRoot /var/www/gabrix
     ErrorLog /var/log/apache2/gabrix_error.log
     TransferLog /var/log/apache2/gabrix_access.log
<IfModule mod_security.c>
     CustomLog /var/log/apache2/gabrix_modsec_custom_log \
        "%h %l %u %t \"%r\" %>s %b %{mod_security-message}i" \
        env=mod_security-relevant
</IfModule>
</VirtualHost>

<VirtualHost x.gabrix.ath.cx>
     ServerName x.gabrix.ath.cx
     ServerAlias x.gabrix.cx
     ServerAdmin gabrix@gabrix.ath.cx
     DocumentRoot /var/www/ics
     ErrorLog /var/log/apache2/x_error.log
     TransferLog /var/log/apache2/x_access.log
<IfModule mod_security.c>
     CustomLog /var/log/apache2/x_modsec_custom_log \
        "%h %l %u %t \"%r\" %>s %b %{mod_security-message}i" \
        env=mod_security-relevant
</IfModule>
</VirtualHost>
And this is the /etc/apache2/sites-enabled/ics file:
Code:
NameVirtualHost x.gabrix.ath.cx
<VirtualHost x.gabrix.ath.cx>
	ServerAdmin webmaster@gabrix.ath.cx
	
	DocumentRoot /var/www/ics
	<Directory />
		Options FollowSymLinks
		AllowOverride None
                Order allow,deny
                allow from 127.0.0.1/8
                allow from 192.168.1.0/29
                deny from all
	</Directory>
	<Directory /var/www/ics/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
		# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
		#RedirectMatch ^/$ /apache2-default/
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/x_error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/x_access.log combined
	ServerSignature Off

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
This morning i added the first page of content and i had back a "page not found" but maybe it's an another issue .
ciao.
__________________
http://www.gabrix.ath.cx
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP doesn't work! JimmiJames Server Operation 1 30th January 2007 12:30
apache virtualhosts permission deneid rolamento Installation/Configuration 3 23rd July 2006 01:36
Apache/Mailman/Postfix VirtualHosts Problem kisong Server Operation 1 15th July 2006 14:09
apache2 not really running blackflag Installation/Configuration 4 9th May 2006 07:50
Domain added multiple times to config adamluz Installation/Configuration 3 11th October 2005 21:52


All times are GMT +2. The time now is 01:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.