Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 22nd January 2007, 22:10
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
Default

I use DynDns.org for my dynamic ip.They offer other services like MailHop Forward , MailHop Relay and MailHop OutBound.You can check here https://www.dyndns.com/services/ What do you advice me to do to?I was thinking to the OutBound , but i'm not sure which will be proper . How should i configure postfix for it and resolve my blacklisted domain ???? Thanks !
__________________
http://www.gabrix.ath.cx

Last edited by gabrix; 22nd January 2007 at 22:13.
Reply With Quote
Sponsored Links
  #22  
Old 23rd January 2007, 18:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by gabrix
I use DynDns.org for my dynamic ip.They offer other services like MailHop Forward , MailHop Relay and MailHop OutBound.You can check here https://www.dyndns.com/services/ What do you advice me to do to?I was thinking to the OutBound , but i'm not sure which will be proper . How should i configure postfix for it and resolve my blacklisted domain ???? Thanks !
So you're using a dynamic IP address. I'm sure this is the reason you're blocked. Most dynamic IP addresses are blocked nowadays because spammers used to use dynamic IP addresses.

Quote:
192.168.0.2 argo.gabrix.ath.cx argo squid.gabrix.ath.cx
192.168.1.1 argo.gabrix.ath.cx gateway
You listed two different IP addresses for argo in /etc/hosts. I think that's the cause of the
Quote:
warning: smtpd_peer_init: 192.168.1.1: address not listed for hostname argo
error.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #23  
Old 23rd January 2007, 20:08
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
Default

I have been sending emails user@gabrix.ath.cx for nearly 1 year and a half by now and all of a sudden this isp planetary decision to consider dynamic ips as spam .... If there was a way to alias my domain name with a more common .org or .it at dns level ...
Quote:
Originally Posted by Falko
You listed two different IP addresses for argo in /etc/hosts. I think that's the cause of the
I have that error in a way or the other anyway if you look my previous /etc/hosts posts you'd see ... i'm depressed i had such an efficient personal mail system once ....
__________________
http://www.gabrix.ath.cx
Reply With Quote
  #24  
Old 24th January 2007, 13:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by gabrix
I have been sending emails user@gabrix.ath.cx for nearly 1 year and a half by now and all of a sudden this isp planetary decision to consider dynamic ips as spam .... If there was a way to alias my domain name with a more common .org or .it at dns level ...
You should consider relaying through another mail server (e.g. the one of your ISP): http://www.howtoforge.com/forums/sho...ight=relayhost
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 24th January 2007, 20:17
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
Default

I have set the postfix to relay on smtp.gmail.com this what i added to main.cf:
Code:
relayhost = smtp.gmail.com
smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
libsasl is configured and this is what is in sasl_passwd:
Code:
smtp.gmail.com  sickuser@gmail.com:xagsdji8jdf
I'm using my actual gmail account.
Quote:
Jan 24 19:53:11 mail postfix/smtp[21126]: connect to smtp.gmail.com [66.249.83.109]: read timeout (port 25)
Jan 24 19:53:11 mail postfix/smtp[21126]: connect to smtp.gmail.com [66.249.83.109]: read timeout (port 25)
Jan 24 19:53:13 mail postfix/qmgr[20977]: B77CC1BFC2: removed
Jan 24 19:53:13 mail postfix/qmgr[20977]: B77CC1BFC2: removed
Jan 24 19:53:13 mail postfix/qmgr[20977]: C85891BF99: removed
Jan 24 19:53:13 mail postfix/qmgr[20977]: C85891BF99: removed
__________________
http://www.gabrix.ath.cx
Reply With Quote
  #26  
Old 24th January 2007, 23:20
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
Default

Realying mail to gmail requires mandatorly the use of saal2-bin package right ?So i have set my postfix accordingly to some tutorials i have foung here but now my password get rejected these are my settings:
Code:
root@mail:~# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_list = 192.168.1.0/24 ,192.168.0.0/24
delay_warning_time = 4h
disable_dns_lookups = yes
home_mailbox = Maildir/
inet_interfaces = all
mailbox_size_limit = 0
message_size_limit = 0
mydestination = $mydomain, mail.gabrix.ath.cx, www.gabrix.ath.cx, localhost.gabrix.ath.cx, , argo.gabrix.ath.cx, argo,localhost
mydomain = gabrix.ath.cx
myhostname = mail.gabrix.ath.cx
mynetworks = 192.168.1.0/24,192.168.0.0/24,127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost = gmail-smtp.l.google.com
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated,reject_unauth_destination, permit
smtpd_reject_unlisted_recipient = no
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options =
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/cert.pem
smtpd_tls_key_file = /etc/postfix/ssl/key.pem
smtpd_tls_loglevel = 1
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
The file /etc/postfix/sasl/sasl_passwd only contains this:
Code:
gmail-smtp.l.google.com       sickuser@gmail.com:dhghghjf
I have CP hosts localtime nsswitch.conf resolv.conf services to /var/spool/postfix/etc shall i CP also passwd to that dir ?How do i say to postfix of new passwd location ?
and in logs i get this:
Code:
Jan 24 22:55:22 mail postfix/smtpd[24109]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
And finally the connection result with smtp.gmail.com
Code:
Jan 25 00:55:53 mail postfix/smtp[25301]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 00:55:53 mail postfix/smtp[25301]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=20:unable to get local issuer certificate
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=20:unable to get local issuer certificate
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=27:certificate not trusted
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=27:certificate not trusted
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=21:unable to verify the first certificate
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=21:unable to verify the first certificate
Jan 25 00:55:59 mail postfix/smtp[25301]: Peer certificate could not be verified
Jan 25 00:55:59 mail postfix/smtp[25301]: Peer certificate could not be verified
Jan 25 00:56:09 mail postfix/qmgr[24799]: 826FF1BFB9: removed
Jan 25 00:56:09 mail postfix/qmgr[24799]: 826FF1BFB9: removed
This is a log update
Code:
Jan 25 04:02:54 mail postfix/smtp[4527]: warning: SASL authentication failure: No worthy mechs found
Jan 25 04:02:54 mail postfix/smtp[4527]: warning: SASL authentication failure: No worthy mechs found
Jan 25 04:02:54 mail postfix/smtp[4527]: 0B7A71BFB7: to=<gabrix@gabrix.ath.cx>, relay=gmail-smtp.l.google.com[72.14.205.109], delay=27, status=deferred (Authentication failed: cannot SASL authenticate to server gmail-smtp.l.google.com[72.14.205.109]: no mechanism available)
That's where i got smtp.gmail.com connection details and instructions to set a relayhost on postfix with gmail:
http://groups.google.com/group/alt.c...03d95?lnk=raot
__________________
http://www.gabrix.ath.cx

Last edited by gabrix; 25th January 2007 at 07:42.
Reply With Quote
  #27  
Old 25th January 2007, 07:54
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
Default

After few hours these are the changes i made to main.cf
Code:
< smtp_sasl_auth_enable = yes
< smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
---
> smtp_sasl_auth_enable = no
> smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
29,30c29,30
< smtpd_sasl_auth_enable = yes
< smtpd_sasl_local_domain = $myhostname
---
> smtpd_sasl_auth_enable = no
> smtpd_sasl_local_domain = $mydomain
36a37
> smtpd_tls_received_header = yes
At the list now i can send mails ... they don'get delivered still but i better go on carefull.
This instead is a log after i sent an email to my libero account:
Code:
Jan 25 07:36:45 mail postfix/smtp[8225]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 07:36:45 mail postfix/smtp[8225]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 07:36:48 mail postfix/smtp[8225]: verify error:num=20:unable to get local issuer certificate
Jan 25 07:36:48 mail postfix/smtp[8225]: verify error:num=20:unable to get local issuer certificate
Jan 25 07:36:48 mail postfix/smtp[8225]: verify error:num=27:certificate not trusted
Jan 25 07:36:48 mail postfix/smtp[8225]: verify error:num=27:certificate not trusted
Jan 25 07:36:48 mail postfix/smtp[8225]: verify error:num=21:unable to verify the first certificate
Jan 25 07:36:48 mail postfix/smtp[8225]: verify error:num=21:unable to verify the first certificate
Jan 25 07:36:51 mail postfix/smtp[8225]: Peer certificate could not be verified
Jan 25 07:36:51 mail postfix/smtp[8225]: Peer certificate could not be verified
Jan 25 07:36:57 mail postfix/smtp[8225]: C5AC51BFAC: to=<gabriele2003@libero.it>, relay=gmail-smtp.l.google.com[66.249.83.1
11], delay=35, status=bounced (host gmail-smtp.l.google.com[66.249.83.111] said: 530 5.5.1 Authentication Required i14sm205
6736wxd (in reply to MAIL FROM command))
Jan 25 07:36:57 mail postfix/smtp[8225]: C5AC51BFAC: to=<gabriele2003@libero.it>, relay=gmail-smtp.l.google.com[66.249.83.1
11], delay=35, status=bounced (host gmail-smtp.l.google.com[66.249.83.111] said: 530 5.5.1 Authentication Required i14sm205
6736wxd (in reply to MAIL FROM command))
Jan 25 07:37:01 mail postfix/cleanup[8224]: 0775A1BFB7: message-id=<20070125063701.0775A1BFB7@mail.gabrix.ath.cx>
Jan 25 07:37:01 mail postfix/cleanup[8224]: 0775A1BFB7: message-id=<20070125063701.0775A1BFB7@mail.gabrix.ath.cx>
Jan 25 07:37:01 mail postfix/qmgr[8051]: 0775A1BFB7: from=<>, size=2573, nrcpt=1 (queue active)
Jan 25 07:37:01 mail postfix/qmgr[8051]: 0775A1BFB7: from=<>, size=2573, nrcpt=1 (queue active)
Jan 25 07:37:01 mail postfix/qmgr[8051]: C5AC51BFAC: removed
Jan 25 07:37:01 mail postfix/qmgr[8051]: C5AC51BFAC: removed
Jan 25 07:37:01 mail postfix/local[8231]: 0775A1BFB7: to=<gabrix@gabrix.ath.cx>, relay=local, delay=0, status=sent (deliver
ed to maildir)
Jan 25 07:37:01 mail postfix/local[8231]: 0775A1BFB7: to=<gabrix@gabrix.ath.cx>, relay=local, delay=0, status=sent (deliver
ed to maildir)
Jan 25 07:37:01 mail postfix/qmgr[8051]: 0775A1BFB7: removed
These are the data of the mail bounced from libero.it:
Code:
<gabriele2003@libero.it>: host gmail-smtp.l.google.com[66.249.83.111] said: 530
    5.5.1 Authentication Required i14sm2056736wxd (in reply to MAIL FROM
    command)
__________________
http://www.gabrix.ath.cx

Last edited by gabrix; 25th January 2007 at 08:04.
Reply With Quote
  #28  
Old 25th January 2007, 08:37
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
 
Default

EUREKA!!!! Risolto !!!
The relay worked finally !
These are the changes i made to main.cf :
Quote:
< relayhost = gmail-smtp.l.google.com
< smtp_sasl_auth_enable = no
---
> relayhost = [gmail-smtp.l.google.com]
> smtp_sasl_auth_enable = yes
23a24,25
> smtp_sasl_security_options =
> smtp_sasl_tls_security_options = noanonymous
31d32
< smtpd_sasl_security_options =
and this is the log:
Code:
Jan 25 08:16:51 mail postfix/smtp[8894]: 8AC7E1BFAC: to=<gabrix666k@yahoo.it>, relay=gmail-smtp.l.google.com[66.249.83.111]
, delay=52, status=sent (250 2.0.0 OK 1169709395 h8sm2156071wxd)
Jan 25 08:16:51 mail postfix/smtp[8894]: 8AC7E1BFAC: to=<gabrix666k@yahoo.it>, relay=gmail-smtp.l.google.com[66.249.83.111]
, delay=52, status=sent (250 2.0.0 OK 1169709395 h8sm2156071wxd)
I sent this mail to my yahoo account there are still some i hope details to consider looking at logs:
Code:
Jan 25 08:16:20 mail postfix/smtp[8894]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 08:16:20 mail postfix/smtp[8894]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 08:16:23 mail postfix/smtp[8894]: verify error:num=20:unable to get local issuer certificate
Jan 25 08:16:23 mail postfix/smtp[8894]: verify error:num=20:unable to get local issuer certificate
Jan 25 08:16:23 mail postfix/smtp[8894]: verify error:num=27:certificate not trusted
Jan 25 08:16:23 mail postfix/smtp[8894]: verify error:num=27:certificate not trusted
Jan 25 08:16:23 mail postfix/smtp[8894]: verify error:num=21:unable to verify the first certificate
Jan 25 08:16:23 mail postfix/smtp[8894]: verify error:num=21:unable to verify the first certificate
Jan 25 08:16:26 mail postfix/smtp[8894]: Peer certificate could not be verified
Jan 25 08:16:26 mail postfix/smtp[8894]: Peer certificate could not be verified
Should i get worried of these errors ?Where do they come from ???Is it because they are selfsigned certificates ?
The mail arrived to yahoo using this email "gabrix" <sickuser@gmail.com> and pukka !!!All sorted out !!!
__________________
http://www.gabrix.ath.cx

Last edited by gabrix; 25th January 2007 at 11:40.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Postfix using "Virtual Users And Domains With Postfix, Courier And MySQL" Kyse HOWTO-Related Questions 15 6th January 2007 15:35
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Postfix refusing smtp connections chrisc Installation/Configuration 4 17th July 2006 15:53
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20


All times are GMT +2. The time now is 08:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.