Prev Previous Post   Next Post Next
  #1  
Old 22nd January 2007, 17:46
d3th_n1gG4 d3th_n1gG4 is offline
Junior Member
 
Join Date: Sep 2006
Location: Durban, South Africa
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default pure-ftp woes

Hi there

I set up my server a couple of months ago and used the pure-ftp with mysql how to on the site and my server has been a happy camper until about 2 weeks ago, 2 events occurred not sure which one borked the server though.

The first was an update via apt-get upgrade, the second was someone trying to brute force the server, looked like a zombie script. So I turned off the server as it was not needed for a day or so then fired it up again

Once it was up I noticed the following. When I try and connect (I use filezilla as a client) i get the following

Code:
Status:	Connecting to <server> ...
Status:	Connected with <server>. Waiting for welcome message...
Response:	220---------- Welcome to Pure-FTPd ----------
Response:	220-You are user number 1 of 50 allowed.
Response:	220-Local time is now 17:16. Server port: 21.
Response:	220-IPv6 connections are also welcome on this server.
Response:	220 You will be disconnected after 15 minutes of inactivity.
Command:	USER <user>
Response:	331 User <user> OK. Password required
Command:	PASS ********
Response:	230-User <user>has group access to:  ftpgroup
Response:	230 OK. Current restricted directory is /
Command:	FEAT
Response:	211-Extensions supported:
Response:	 EPRT
Response:	 IDLE
Response:	 MDTM
Response:	 SIZE
Response:	 REST STREAM
Response:	 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response:	 MLSD
Response:	 ESTP
Response:	 PASV
Response:	 EPSV
Response:	 SPSV
Response:	 ESTA
Response:	211 End.
Command:	SYST
Response:	215 UNIX Type: L8
Status:	Connected
Status:	Retrieving directory listing...
Command:	PWD
Response:	257 "/" is your current location
Command:	TYPE A
Response:	200 TYPE is now ASCII
Command:	PASV
Response:	227 Entering Passive Mode (88,198,5,149,192,40)
Command:	LIST
Error:	Transfer channel can't be opened. Reason: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Error:	Could not retrieve directory listing
Command:	REST 0
Error:	Timeout detected!
Status:	Waiting to retry... (5 retries left)
I thought it may initially be an issue with my user but it seems to affect all users, the other thing I did notice is that the virtual ftp user has no write access on their directory, and I have to manually chmod/chown the directory this however has been around since day 1 of my install.

The actual ftp user is set to "No login allowed" in webmin and their home directory is set to /bin/null, and the virtual ftp users UID & GID are correct, I am at a bit of a loss here, any tips?
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Routing multiple FTP servers koroshiya1 Server Operation 5 1st August 2006 13:28
ftp problems tgansert Installation/Configuration 20 27th May 2006 20:06
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 09:03
Website users? ctroyp General 25 6th January 2006 19:02
FTP 101 the basics koegies Installation/Configuration 7 17th November 2005 16:55


All times are GMT +2. The time now is 17:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.