Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 20th January 2007, 08:10
Chrisssssss Chrisssssss is offline
Junior Member
 
Join Date: Jan 2007
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is /etc/hosts

Code:
# 
# Do not remove the following line, or various programs
# that require network functionality will fail.



127.0.0.1              localhost.localdomain localhost
85.17.97.14             cip001.france-tracker.net
this is /etc/host.conf
Code:
order hosts,bind
~
~
~
and this is /etc/resolv.conf
Code:
search www.france-tracker.net
nameserver 85.17.97.14
Reply With Quote
Sponsored Links
  #22  
Old 20th January 2007, 14:07
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

I think you run your own DNS, right? If yes, comment both lines in resolv.conf. The DNS forward should be done in your own Bind/Named configuration with the 'forward' directive.

The 'search www.france-tracker.net' line should be commented out, if you have your hosts/DNS oke. Your system is now trying to find local.localdomain.www.france-tracker.net, which I'm pretty sure, does not exist.
Reply With Quote
  #23  
Old 20th January 2007, 16:28
Chrisssssss Chrisssssss is offline
Junior Member
 
Join Date: Jan 2007
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello thanks for your help
Yes I use Bind for my DNS and I dont have a ligne whith local.localdomain.www.france-tracker.net But my english and my administration is not good i am studied this. And I not sure to understand very well this.
Whats I do modifie for repar my probleme please
Reply With Quote
  #24  
Old 20th January 2007, 16:33
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Edit /etc/resolv.conf to make it look like:
Code:
# search www.france-tracker.net
nameserver 85.17.97.14
for starters. The # sign means to turn a line into a comment. Check if sending mail now works. If not, the next step is to change the way address resolving is done. We'll do that if this step does not work. Oke?
Reply With Quote
  #25  
Old 20th January 2007, 16:49
Chrisssssss Chrisssssss is offline
Junior Member
 
Join Date: Jan 2007
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your help I test this
Reply With Quote
  #26  
Old 20th January 2007, 17:01
Chrisssssss Chrisssssss is offline
Junior Member
 
Join Date: Jan 2007
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

After to change this my mail server accept to send mail but mail don t enter
I have reload postfix after this change.
And after has reput this to
search www.france-tracker.net
nameserver 85.17.97.14
my serveur mail dont restart correctly it s refused my mail but I have still the mail not delivery

Last edited by Chrisssssss; 20th January 2007 at 17:05.
Reply With Quote
  #27  
Old 20th January 2007, 17:20
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

I did some more testing:
Code:
:~# dig MX france-tracker.net

; <<>> DiG 9.3.2-P1 <<>> MX france-tracker.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18558
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;france-tracker.net.            IN      MX

;; AUTHORITY SECTION:
france-tracker.net.     3559    IN      SOA     ns1.domainpeople.com. root.domainpeople.com. 2001050903 28800 14400 3600000 3600

;; Query time: 3 msec
;; SERVER: 172.16.3.70#53(172.16.3.70)
;; WHEN: Sat Jan 20 17:08:53 2007
;; MSG SIZE  rcvd: 97
Apparantly you have not set your DNS MX record. Thus, external sites do not know to which server / IP they have to connect to deliver mail.

To setup a MX record, go to your DNS manager in ISPConfig, click on your site, and go to the tab 'records'.

Scroll down till you see MX with a new button. I think there's no entry for MX, right? Click on the new button, leave the hostname field empty and enter your system name (cip001.france-tracker.net) in the mailserver field. Press save.

Now this is DNS, so it may take a while before it is propagated all over the world. You can check this yourself. Mail should start to work by using the dig command above. You should see a line somewhere in the middle saying:
Code:
......
;; ANSWER SECTION:
france-tracker.net.              86400   IN      MX      10 cip001.france-tracker.net.
.....
Then start testing your email again.
Reply With Quote
  #28  
Old 20th January 2007, 18:23
Chrisssssss Chrisssssss is offline
Junior Member
 
Join Date: Jan 2007
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your reponse but I am not sour to file to modify /etc/named.conf or /var/named/france-tracker.zone or another file but I dont wont to modifiy the bad file.
I your answer waits and thanks for this
Reply With Quote
  #29  
Old 20th January 2007, 19:30
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Sorry, I have no idea what your trying to say. Did I mention anything about changing /etc/named.conf or /var/named/france-tracker.zone ? No, I told you the steps in the grafical interface of ISPConfig, which I assume you use, as you posted your question in the ISPConfig forum and you state "ISPConfig & postfix error".

Please do the steps as I described in my previous post in ISPConfig and the actual files will be modified in the right locations in the right place for you. No manual editing. If you get errors, we'll start over from there.

Without a MX record, you will never receive email from the internet.
Reply With Quote
  #30  
Old 20th January 2007, 19:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Please put
Code:
order hosts,bind
multi on
in /etc/host.conf and run
Code:
postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
postconf -e 'mydestination = /etc/postfix/local-host-names'
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Change MTA from Postfix to Sendmail in ISPConfig denmaus Installation/Configuration 8 10th July 2006 13:01
Postfix problem : read timeout DarkBen General 14 21st April 2006 12:39
ISPCONFIG installation problem with Fedora Core 4 (64 bit) dchowdhu Installation/Configuration 5 25th January 2006 06:21
ISPConfig pop3 problem mphayesuk General 21 31st October 2005 10:53
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37


All times are GMT +2. The time now is 16:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.