Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 12th January 2007, 09:59
massimopasquali massimopasquali is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 2 Times in 1 Post
Default

this is my main.cf

command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
setgid_group = postdrop

append_dot_mydomain = no

smtp_banner = $myhostname ESMTP pasqualinformatica.com
biff = no

myhostname =smtp.pasqualinformatica.com

mydestination = $myhostname loalhost localhost.$mydomain

#relay_domains =
mynetworks = 127.0.0.1/8, 192.168.3.0/24

disable_vrfy_command = yes
smtpd_helo_required = yes


virtual_mailbox_base = /var/mail/vmail
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf

virtual_alias_domains = $virtual_alias_maps
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf

virtual_uid_maps = static:1008
virtual_gid_maps = static:1008

alias_maps = mysql:/etc/postfix/mysql-alis_maps.cf

smtpd_sender_restrictions = permit_sasl_authenticated,
permit_mynetworks

smtpd_recipient_restrictions = permit_sasl_authenticated,
permit_mynetworks,
reject_unauth_destination


smtpd_sasl_auth_enable = yes
#smtpd_sasl_local_domain = yes
smtpd_sasl_security_options = noanonymous
smtp_sasl_password_maps = mysql:/etc/postfix/mysql_auth.conf
smtp_sender_login_maps = mysql:/etc/postfix/mysql_auth.conf

smtpd_pix_workaround_delay_time = 20s
smtpd_pix_workaround_threshold_time = 500s

#message_size_limit = 10240000
message_size_limit = 20240000
#message_size_limit = 3000000


can you look please? becouse I am becoming crazy

thanks
Reply With Quote
Sponsored Links
  #12  
Old 13th January 2007, 16:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Did you enable "Server requires authentication" in your email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 13th January 2007, 17:40
massimopasquali massimopasquali is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 2 Times in 1 Post
Default

yes i do it
Reply With Quote
  #14  
Old 14th January 2007, 19:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

And do you use the correct username and password in your email client?

What's the output of
Code:
telnet localhost 25
ehlo localhost
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 11th February 2007, 21:32
xionax xionax is offline
Junior Member
 
Join Date: Jan 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
And do you use the correct username and password in your email client?

What's the output of
Code:
telnet localhost 25
ehlo localhost
?
I'm encountering the exact same problem.
The output is, for me:

Code:
anderith:~# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 anderith.rg-it.net ESMTP Postfix (Debian/GNU)
ehlo localhost
250-anderith.rg-it.net
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250 8BITMIME
- SMTP authentication is enabled
Postconf -n is:

Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
delay_warning_time = 4h
home_mailbox = Maildir/
inet_interfaces = all
mailbox_command =
mailbox_size_limit = 0
mydestination = /etc/postfix/local-host-names
myhostname = anderith.rg-it.net
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost =
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
cat /etc/postfix/virtusertable:

Code:
anderith:~# cat /etc/postfix/virtusertable
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
support@www.rg-it.net    web2_rgit
web2_rgit@www.rg-it.net    web2_rgit
support@rg-it.net    web2_rgit
web2_rgit@rg-it.net    web2_rgit
support@rails.rg-it.net    web2_rgit
web2_rgit@rails.rg-it.net    web2_rgit
robert@www.xs4some.org    web3_robert
web3_robert@www.xs4some.org    web3_robert
robert@xs4some.org    web3_robert
web3_robert@xs4some.org    web3_robert
robert@xs4some.org..xs4some.org    web3_robert
web3_robert@xs4some.org..xs4some.org    web3_robert
robert@blog.xs4some.org    web3_robert
web3_robert@blog.xs4some.org    web3_robert
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####anderith:~#
cat /etc/postfix/local-host-names:

Code:
anderith:~# cat /etc/postfix/local-host-names
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
anderith.rg-it.net
localhost.anderith.rg-it.net
localhost.rg-it.net
localhost.localdomain
www.xerox.rg-it.net
www.rg-it.net
www.xs4some.org
xerox.rg-it.net
rg-it.net
rails.rg-it.net
xs4some.org
xs4some.org..xs4some.org
blog.xs4some.org
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####anderith:~#
Situation: I'm trying to send an email - from Outlook - to an @gmail.com address.
Internal (within my @xs4some.org domain) works OK, webmail works OK, telnet locally works ok, telnet externally doesn't work.
And ofcourse; from Outlook it doesn't work.

Some help is definitely appreciated.

edit:
Almost forgot to mention; I'm running Debian Sarge.

Last edited by xionax; 11th February 2007 at 21:40.
Reply With Quote
  #16  
Old 12th February 2007, 16:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by xionax
Almost forgot to mention; I'm running Debian Sarge.
By reading the output of postconf -n, I assume you didn't follow the "Perfect Setup for Debian Sarge"? Please configure your Postfix as described here: http://www.howtoforge.com/perfect_setup_debian_sarge_p4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 28th May 2007, 00:16
nevernamed nevernamed is offline
Junior Member
 
Join Date: May 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same Problem

I seem to be having the same problem.
When I log into my webmail (squirrelmail) I can send mail no problem. I sent mail to my gmail and it got there. However, when I try to send mail through my thunderbird e-mail client I get the relay access denied error.
This is odd because I've had no problems with this system for about a month since I initially got it running. Does anybody have any idea what within my client could be causing the problem? Thanks!
Reply With Quote
  #18  
Old 28th May 2007, 18:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Did you enable "Server requires authentication." in your email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 29th May 2007, 03:43
nevernamed nevernamed is offline
Junior Member
 
Join Date: May 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I did. I just got home and I tried it again and I was able to send mail (to my gmail). This leads me to believe that it's just something now allowing me to send mail from outside of my network. Do you know what it might be? The only mail port that I have open is 993.... could that be the problem?
Reply With Quote
  #20  
Old 30th May 2007, 17:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

"Server requires authentication." allows your mail client to use SMTP-AUTH which is required to send mails outside your server.

Port 993 is for IMAPS. For sending emails, port 25 (SMTP) must be open.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied maxx Installation/Configuration 17 4th April 2011 13:34
Access denied in phpMyAdmin linuxfast General 1 21st September 2005 17:08
Access Denied on Port: 81 nandhu Installation/Configuration 2 10th August 2005 15:05


All times are GMT +2. The time now is 21:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.