Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th January 2007, 23:46
AZMel AZMel is offline
Junior Member
 
Join Date: Nov 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Undelivered Mail - What could I have missed in configuration?

I have 25 users setup and all work fine but my account keeps getting this e-mail about every 20 seconds or so. I am able to send and receive e-mails, this one just happens to keeps showing up in my inbox.



Quote:
This is the Postfix program at host yyy.org.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The Postfix program

<admispconfig@localhost.localdomain>: Host or domain name not found. Name
service error for name=localhost.localdomain type=A: Host not found



Reporting-MTA: dns; yyy.org
X-Postfix-Queue-ID: DB81D8605
X-Postfix-Sender: rfc822; xxx@yyyy.org
Arrival-Date: Wed, 10 Jan 2007 15:34:06 -0700 (MST)

Final-Recipient: rfc822; admispconfig@localhost.localdomain
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
for name=localhost.localdomain type=A: Host not found
Thanks for your help,

Mel

Last edited by AZMel; 10th January 2007 at 23:50.
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2007, 00:09
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

Have a look at this thread http://www.howtoforge.com/forums/showthread.php?t=9626
Reply With Quote
  #3  
Old 11th January 2007, 00:45
AZMel AZMel is offline
Junior Member
 
Join Date: Nov 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

local-host-names already had localhost.localdomain listed and /etc/hosts does have localhost.localdomain pointing to 127.0.0.1. Anything else I can try?

And one more item to note, I was notified by all the users that they are being effected by this as well so it is no longer isolated as I was thinking it was.

Quote:
/etc/postfix/local-host-names
###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
www.yyy.org
localhost.www.yyy.org
localhost.yyy.org
localhost.localdomain
yyy.org
mail.yyy.org
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
localhost.localdomain

/etc/hosts
127.0.0.1 localhost.localdomain localhost www
192.169.30.10 www.yyy.org www
192.169.30.101 www.yyy.org yyy.org
192.168.30.10 mail.yyy.org mail
# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Here is some output from mail.log
Quote:
Jan 10 16:42:55 www postfix/smtp[31221]: BFDEE16A9: to=<admispconfig@localhost.l
ocaldomain>, relay=none, delay=21, status=bounced (Host or domain name not found
. Name service error for name=localhost.localdomain type=A: Host not found)
Jan 10 16:42:55 www postfix/cleanup[1016]: 0BEEA1882: message-id=<20070110234255
.0BEEA1882@yyy.org>
Jan 10 16:42:55 www postfix/qmgr[30903]: 0BEEA1882: from=<>, size=2112, nrcpt=1
(queue active)
Jan 10 16:42:55 www postfix/qmgr[30903]: BFDEE16A9: removed
Jan 10 16:42:55 www postfix/smtp[31222]: BC78D1634: to=<admispconfig@localhost.l
ocaldomain>, relay=none, delay=21, status=bounced (Host or domain name not found
. Name service error for name=localhost.localdomain type=A: Host not found)
Jan 10 16:42:55 www postfix/cleanup[6568]: 16B1D16A9: message-id=<20070110234255
.16B1D16A9@yyy.org>
Jan 10 16:42:55 www postfix/qmgr[30903]: 16B1D16A9: from=<>, size=2095, nrcpt=1
(queue active)
Jan 10 16:42:55 www postfix/qmgr[30903]: BC78D1634: removed
Jan 10 16:42:55 www postfix/smtp[31219]: 12ECB1A18: to=<admispconfig@localhost.l
ocaldomain>, relay=none, delay=16, status=bounced (Host or domain name not found
. Name service error for name=localhost.localdomain type=A: Host not found)
Jan 10 16:42:55 www postfix/cleanup[6570]: E85DC163A: message-id=<20070110234255
.E85DC163A@yyy.org>
Jan 10 16:42:55 www postfix/qmgr[30903]: E85DC163A: from=<>, size=2108, nrcpt=1
(queue active)
Jan 10 16:42:55 www postfix/qmgr[30903]: 12ECB1A18: removed
Jan 10 16:42:55 www postfix/smtp[31475]: 143D21A21: to=<admispconfig@localhost.l
ocaldomain>, relay=none, delay=16, status=bounced (Host or domain name not found
. Name service error for name=localhost.localdomain type=A: Host not found)
Jan 10 16:42:55 www postfix/smtp[31474]: 31ADB1966: to=<admispconfig@localhost.l
ocaldomain>, relay=none, delay=16, status=bounced (Host or domain name not found
. Name service error for name=localhost.localdomain type=A: Host not found)
Jan 10 16:42:55 www postfix/cleanup[3741]: F3EE61A50: message-id=<20070110234255
.F3EE61A50@yyy.org>
Jan 10 16:42:55 www postfix/cleanup[6571]: F3E241A18: message-id=<20070110234255
.F3E241A18@yyy.org>
Jan 10 16:42:56 www postfix/smtp[30907]: 3475D1774: to=<admispconfig@localhost.l
ocaldomain>, relay=none, delay=17, status=bounced (Host or domain name not found
. Name service error for name=localhost.localdomain type=A: Host not found)
Jan 10 16:42:56 www postfix/qmgr[30903]: F3E241A18: from=<>, size=2098, nrcpt=1
(queue active)
Jan 10 16:42:56 www postfix/qmgr[30903]: 143D21A21: removed
Jan 10 16:42:56 www postfix/qmgr[30903]: 31ADB1966: removed
Jan 10 16:42:56 www postfix/qmgr[30903]: F3EE61A50: from=<>, size=2095, nrcpt=1
(queue active)
Jan 10 16:42:56 www postfix/cleanup[6569]: 0140F1A62: message-id=<20070110234256
.0140F1A62@yyy.org>
Jan 10 16:42:56 www postfix/qmgr[30903]: 0140F1A62: from=<>, size=2097, nrcpt=1
(queue active)
Jan 10 16:42:56 www postfix/qmgr[30903]: 3475D1774: removed

Last edited by AZMel; 11th January 2007 at 01:19.
Reply With Quote
  #4  
Old 11th January 2007, 03:15
AZMel AZMel is offline
Junior Member
 
Join Date: Nov 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did not think to say this earlier but this happened after i upgraded from ispconfig 2.1.0 to 2.2.9.
Reply With Quote
  #5  
Old 11th January 2007, 04:31
AZMel AZMel is offline
Junior Member
 
Join Date: Nov 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here are some more details.

This is a complete listing of a failed E-mail
Code:
Return-Path: <>
X-Spam-Checker-Version: SpamAssassin 3.1.7 (2006-10-05) on www.yyy.org
X-Spam-Level: 
X-Spam-Status: No, score=-2.1 required=5.0 tests=AWL,BAYES_00,NO_RELAYS 
	autolearn=ham version=3.1.7
X-Original-To: postmaster@yyy.org
Delivered-To: postmaster@yyy.org
Received: by yyy.org (Postfix)
	id B731995EF; Wed, 10 Jan 2007 19:52:30 -0700 (MST)
Date: Wed, 10 Jan 2007 19:52:30 -0700 (MST)
From: MAILER-DAEMON@yyy.org (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
To: postmaster@yyy.org
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
	boundary="2F4549536.1168483950/yyy.org"
Message-Id: <20070111025230.B731995EF@yyy.org>
X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.3 with clamscan / ClamAV 0.88.7/2434/Wed Jan 10 17:47:38 2007

This is a MIME-encapsulated message.

--2F4549536.1168483950/yyy.org
Content-Description: Notification
Content-Type: text/plain

This is the Postfix program at host yyy.org.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

			The Postfix program

<admispconfig@localhost.localdomain>: Host or domain name not found. Name
    service error for name=localhost.localdomain type=A: Host not found

--2F4549536.1168483950/yyy.org
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; yyy.org
X-Postfix-Queue-ID: 2F4549536
X-Postfix-Sender: rfc822; postmaster@yyy.org
Arrival-Date: Wed, 10 Jan 2007 19:52:18 -0700 (MST)

Final-Recipient: rfc822; admispconfig@localhost.localdomain
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
    for name=localhost.localdomain type=A: Host not found

--2F4549536.1168483950/yyy.org
Content-Description: Undelivered Message
Content-Type: message/rfc822

Received: by yyy.org (Postfix, from userid 10033)
	id 2F4549536; Wed, 10 Jan 2007 19:52:18 -0700 (MST)
X-Loop: postmaster@localhost.localdomain
Subject: Mailsize: postmaster
Message-Id: <20070111025218.2F4549536@yyy.org>
Date: Wed, 10 Jan 2007 19:52:18 -0700 (MST)
From: postmaster@yyy.org (Postmaster)
To: undisclosed-recipients:;

2184


--2F4549536.1168483950/yyy.org--

Here is a complete detail of a working e-mail.

Code:
Return-Path: <xxx@zzz.net>
X-Spam-Checker-Version: SpamAssassin 3.1.7 (2006-10-05) on www.yyy.org
X-Spam-Level: *
X-Spam-Status: No, score=1.9 required=5.0 tests=DNS_FROM_RFC_ABUSE,
	DNS_FROM_RFC_POST autolearn=no version=3.1.7
X-Original-To: xxx@yyy.org
Delivered-To: xxx@yyy.org
Received: from mta15.adelphia.net (mta15.mail.adelphia.net [68.168.78.77])
	by yyy.org (Postfix) with ESMTP id 205028CD8
	for <xxx@yyy.org>; Wed, 10 Jan 2007 18:55:20 -0700 (MST)
Received: from [192.168.1.109] (really [76.178.79.14])
          by mta15.adelphia.net
          (InterMail vM.6.01.05.04 201-2131-123-105-20051025) with ESMTP
          id <20070111014326.XGTO25578.mta15.adelphia.net@[192.168.1.109]>
          for <xxx@yyy.org>; Wed, 10 Jan 2007 20:43:26 -0500
Message-ID: <45A59906.9030202@adelphia.net>
Date: Wed, 10 Jan 2007 18:55:18 -0700
From: Mel <xxx@zzz.net>
User-Agent: Mozilla Thunderbird 1.0.6 (Windows/20050716)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: Mel <xxx@yyy.org>
Subject: Test;ljkljkl
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.3 with clamscan / ClamAV 0.88.7/2434/Wed Jan 10 17:47:38 2007

sfasffsfdsaf
All seems fine if the incoming e-mail goes to a legit account or if it is spam. It seems that there is an e-mail that keeps getting redelivered to me. I'm not sure where to look at this point.

Any help you can give will be appreciated.

Thanks,
Mel
Reply With Quote
  #6  
Old 11th January 2007, 08:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

The emails to admispconfig@localhost.localdomain are internal messages of ISPConfig to generate statistics.

What is the output of:

ping -c 3 localhost.localdomain

and do you get a smtp prompt when you enter

telnet localhost.localdomain 25

Please post your /etc/hosts file, you can change your real domain, but dont modify the line with localhost.localdomain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 11th January 2007, 13:05
AZMel AZMel is offline
Junior Member
 
Join Date: Nov 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till. Thanks for the reply. Here's what you requested.


Ping Result:

Code:
PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.028 ms

64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.030 ms

64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=3 ttl=64 time=0.031 ms

telnet result:

Code:
root@www:~# telnet localhost.localdomain 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 ycwua.org ESMTP Postfix (Ubuntu)
ehlo localhost.localdomain
250-ycwua.org
250-PIPELINING
250-SIZE 209715200
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
/etc/hosts

Code:
root@www:~# cat /etc/hosts
127.0.0.1       localhost.localdomain   localhost www
192.169.30.10   www.yyy.org   www
192.169.30.101  mail.yyy.org   mail
# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Also I noticed that the date received is from 20 to 60 minutes before the time it is put into the users Inbox. This E-mail fragment was received at 5:55 am but the header shows it came in at 5:08 am. Could this be significant?

Code:
Received: by yyy.org (Postfix)
	id C5228ADD5; Thu, 11 Jan 2007 05:08:26 -0700 (MST)
Date: Thu, 11 Jan 2007 05:08:26 -0700 (MST)
From: MAILER-DAEMON@yyy.org (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
Running top shows that clamscan and spamassassin are taking up alot of CPU time.

Code:
top - 06:03:48 up 14:27,  4 users,  load average: 36.42, 37.93, 37.54
Tasks: 349 total,  35 running, 287 sleeping,   0 stopped,  27 zombie
Cpu(s): 89.7% us,  9.7% sy,  0.0% ni,  0.0% id,  0.0% wa,  0.7% hi,  0.0% si
Mem:   2053692k total,  1863212k used,   190480k free,   125092k buffers
Swap:  3903784k total,    13448k used,  3890336k free,   554740k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 9007 dbodine   18   0 23892  16m  724 R  6.6  0.8   0:00.94 clamscan
 9014 tlawrenc  18   0 24032  16m  724 R  6.6  0.8   0:00.93 clamscan
 9021 tstover   18   0 23892  16m  724 R  6.6  0.8   0:00.94 clamscan
 9000 jmartine  18   0 23892  16m  724 R  5.3  0.8   0:00.94 clamscan
 9053 pclark    19   0 32340  25m  724 R  3.7  1.3   0:01.44 clamscan
 9065 donpope   19   0 32344  25m  724 R  3.7  1.3   0:01.44 clamscan
 9093 ccowan    19   0 26668  19m  724 R  3.7  1.0   0:01.10 clamscan
 9102 postmast  24   0 17896  10m  724 R  3.7  0.5   0:00.64 clamscan
 9103 dbodine   19   0 26668  19m  724 R  3.7  1.0   0:01.10 clamscan
 8816 ccowan    20   0 31044  23m  724 R  3.3  1.2   0:01.34 clamscan
 8824 rray      21   0 31048  23m  724 R  3.3  1.2   0:01.34 clamscan
 8972 postmast  18   0 24032  16m  724 R  3.3  0.8   0:00.94 clamscan
 9082 tlawrenc  20   0 32340  25m  724 R  3.3  1.3   0:01.44 clamscan
 9090 asmith    20   0 32344  25m  724 R  3.3  1.3   0:01.44 clamscan
 9148 mirizarr  20   0  7968 1416  712 R  3.3  0.1   0:00.44 clamscan
 9073 rray      20   0 32340  25m  724 R  3.0  1.3   0:01.43 clamscan
 8776 pclark    18   0 32744  25m  724 R  1.7  1.3   0:01.48 clamscan
 8993 breily    18   0 23088  16m  724 R  1.7  0.8   0:00.88 clamscan

Last edited by AZMel; 11th January 2007 at 14:04.
Reply With Quote
  #8  
Old 11th January 2007, 19:39
AZMel AZMel is offline
Junior Member
 
Join Date: Nov 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I believe I fixed it. I followed the instructions I used to build the system in the first place http://www.howtoforge.com/perfect_setup_ubuntu_5.10 and removed all the installed items and reinstalled them.

Then I removed the install_ispconfig directory and untar the original 2.2.9 install again. I reran the install and all seems to be working now. I am still getting Undelivered Mail but it looks like it is older mail in the queue to be scanned. Where can I go to remove those from the queue?

One thing I did notice that occured this time that did not happen last time was the install_ispconfig directory was removed. This may have been a sign os a failed upgrade.

Mel
Reply With Quote
  #9  
Old 12th January 2007, 11:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by AZMel
Then I removed the install_ispconfig directory and untar the original 2.2.9 install again. I reran the install and all seems to be working now. I am still getting Undelivered Mail but it looks like it is older mail in the queue to be scanned. Where can I go to remove those from the queue?
Run
Code:
postsuper -d ALL
to delete all mails in the mail queue.

Quote:
Originally Posted by AZMel
One thing I did notice that occured this time that did not happen last time was the install_ispconfig directory was removed.
That's the normal behaviour. It's intended like that and is a good sign.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mail for aol.com loops back to myself CODAC Installation/Configuration 15 7th October 2009 14:36
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 15:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.