Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th January 2007, 20:20
chrisp8756 chrisp8756 is offline
Junior Member
 
Join Date: Sep 2006
Location: Aberdeen,Wa,USA
Posts: 12
Thanks: 0
Thanked 2 Times in 1 Post
Question Server running very slow and not responding

Hello,
Running ISPconfig 2.29, I have 41 email accounts created on one domain, the accounts are very active. After about a week of having the domain on the server, now my server is running very slow and nothing is responding. I'm not sure where to even begin. The maillog file is 386,000 plus in size, it appears to me we don't have any problems with the server until those 41 accounts become active and it like kills the server. Not sure where to even began troubleshooting the issue.

Last night while the 41 accounts were idle the server was fine, and things worked like normal. As soon as the business opened and they started using the email accounts boom, running really slow and not responding. Any help would be greatly appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2007, 20:29
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

What's the total amount of emails coming in? Do you do spam scanning (enabled)? Do you have enough memory? Look with 'top' interactively on your server to find your cpu burner (if any). But also watch the swap statistics. If you have swapping going on, that's your problem. In top, you can use the 'm' command to show the most memory intensive programs.
Reply With Quote
  #3  
Old 10th January 2007, 21:00
chrisp8756 chrisp8756 is offline
Junior Member
 
Join Date: Sep 2006
Location: Aberdeen,Wa,USA
Posts: 12
Thanks: 0
Thanked 2 Times in 1 Post
Default will check..

Hello,
Thanks for responding so fast, I have 768 megs of ram, 80 gigs of hard drive space and 62 gigs is free. I will check the ram swap and see what that looks like. Yes I do have spam assassasin running, the domain only has 260 megs used so far. The funny thing is if the business is closed the server does fine, only if there open and actively checking there email using pop3. Thanks for your help I will keep you posted
Reply With Quote
  #4  
Old 10th January 2007, 21:11
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
Originally Posted by chrisp8756
The funny thing is if the business is closed the server does fine, only if there open and actively checking there email using pop3.
That makes me believe you have a shortage of memory. What's the poll rate for your pop3 clients? Maybe setting that to 10 minutes (and not 1 minute as most people do) will already solve this. Or add more memory.
Reply With Quote
  #5  
Old 10th January 2007, 23:34
chrisp8756 chrisp8756 is offline
Junior Member
 
Join Date: Sep 2006
Location: Aberdeen,Wa,USA
Posts: 12
Thanks: 0
Thanked 2 Times in 1 Post
Default What does this mean?

Here is the error message I get when I try to send my self an email-

Command time limit exceeded: "/usr/bin/procmail
-f-". Command output: procmail: Timeout, terminating
"/home/admispconfig/ispconfig/tools/clamav/bin/clamassassin" procmail:
Rescue of unfiltered data succeeded
Reply With Quote
  #6  
Old 11th January 2007, 08:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
 
Default

Do you get an error when you riún:

/home/admispconfig/ispconfig/tools/clamav/bin/clamassassin

Please post the output of:

df -h
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.