Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th January 2007, 21:45
joelee joelee is offline
Member
 
Join Date: Sep 2006
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem upgrading/compiling debian - Pls Help!

Hi All,

I am trying to upgrade and compile debian (sarge) 2.4 to 2.6.18.3. I am following the following how-to:

http://howtoforge.com/howto_linux_ke...compile_debian

All seems to go fine until I reach to the point to install the new kernel with the command:

dpkg -i kernel-image-2.6.8.1_custom.1.0_i386.deb.

Below is a copy/paste of the error I get:

ovz:/usr/src# dpkg -i linux-2.6.18.3-ovz028test007.1_2.6.18.3-ovz028test007.1_i386.deb
(Reading database ... 13978 files and directories currently installed.)
Unpacking linux-2.6.18.3-ovz028test007.1 (from linux-2.6.18.3-ovz028test007.1_2.6.18.3-ovz028test007.1_i386.deb) ...
dpkg: error processing linux-2.6.18.3-ovz028test007.1_2.6.18.3-ovz028test007.1_i386.deb(--install):
failed in buffer_write(fd) (8, ret=-1): backend dpkg-deb during `./boot/System.map-2.6.18.3-ovz028test007.1': No space left on device
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
linux-2.6.18.3-ovz028test007.1_2.6.18.3-ovz028test007.1_i386.deb
ovz:/usr/src#

Any help will be appreciated!
-Joe
Reply With Quote
Sponsored Links
  #2  
Old 8th January 2007, 23:23
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by joelee
failed in buffer_write(fd) (8, ret=-1): backend dpkg-deb during `./boot/System.map-2.6.18.3-ovz028test007.1': No space left on device
One of your partitions is full. What's the output of
Code:
df -h
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th January 2007, 00:21
joelee joelee is offline
Member
 
Join Date: Sep 2006
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falco, thanks for the reply. Below is the info you requested.

Code:
ovz:/usr/src# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda6             1.8G  453M  1.3G  27% /
tmpfs                 253M     0  253M   0% /dev/shm
/dev/sda1             7.4M  7.3M     0 100% /boot
/dev/sda7              47G  107M   45G   1% /var
I see /boot is full I will try a bigger size partition for it and see if that is the problem. Also, based on the partition below would appreciate if you can comment/suggest a better partition scheme to set up OpenVZ. For now this is just on a test VMware setup. Once I get all working I will re-do on a standard machine with 300G HD.
-Joe
Reply With Quote
  #4  
Old 10th January 2007, 17:50
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

1.8GB for / and 7.4MB for /boot are very little. I suggest something like 4GB or more for / and 100MB or more for /boot.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
The Perfect Xen 3.0.3 Setup For Debian Sarge iptables problem on dom0 ren22 HOWTO-Related Questions 21 7th January 2007 19:32
The Perfect Xen 3.0 Setup For Debian - NAT problem amussa HOWTO-Related Questions 9 28th September 2006 21:27
Problem installing 2.2 on Debian Sarge 3.1 bwrob Installation/Configuration 3 3rd March 2006 23:40
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 11:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.