Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 4th January 2007, 21:22
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default Apache2 & SuExec - not working

I've setup a new server, mostly following the Ubuntu 6.10 and ISPConfig guides. All works oke, but during the process of transferring websites to this new server, I'm puzzled by a permission problem between Perl and SuExec and hope someone has an idea.

Although ISPConfig has added the right SuexecUserGroup, it appears that perl scripts do not use this user/group, but instead run with the euid and ruid of apache: www-data in my case. Any suggestion how to tackle this problem further?

Details:
Directory:
Quote:
drwxrwxr-x 30 web1_user web1 4096 2005-10-14 11:27 uploads
Apache2.conf
...
Quote:
<VirtualHost 172.16.3.80:80>
SuexecUserGroup web1_user web1
ServerName www2.xxxx.loc:80
ServerAdmin webmaster@xxxx.loc
DocumentRoot /home/ispwww/web1/web
Error:
Quote:
Thu Jan 4 20:02:35 2007 /home/ispwww/web1/web/index.pl WARNING: euid: 33 ruid: 33 Couldn't create node: /home/ispwww/web1/web/uploads/images/75 : Permission denied
The only other remark to make is that the perl routines/programs called by index.pl are stored outside the webroot. But the whole application works without a problem. If I change the ownership of the uploads directory (including the subdirs) to www-data, the nodes/files are created without any issue.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSI with Apache2 on Debian jchaven Server Operation 7 25th August 2008 18:06
Apache2 without APXS ctroyp Installation/Configuration 8 29th January 2007 04:05
Suexec Not Working helfrez Installation/Configuration 1 13th October 2006 16:52
SuExec compiling qtam0 Server Operation 6 24th September 2006 03:25
PHP on Apache2 no longer works after ISPconfig azorman Installation/Configuration 6 23rd July 2006 23:06


All times are GMT +2. The time now is 00:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.