Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 20th December 2006, 19:21
sapphire327 sapphire327 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)

I worked through this tutorial step by step, and successfully installed everything on a Fedora 5 VMware system. I then proceeded to go through the tutorial again on my actual server, and I ran into a problem:

This is what shows up in /var/log/maillog
Quote:
Dec 20 10:10:53 mail postfix/smtpd[11839]: fatal: no SASL authentication mechanisms
Dec 20 10:10:54 mail postfix/master[3075]: warning: process /usr/libexec/postfix/smtpd pid 11839 exit status 1
Dec 20 10:10:54 mail postfix/master[3075]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
These three lines appear repeatedly in the log file, and running a tail -f on it shows that they appear roughly every minute, and not in response to me trying to connect to port 25.

Trying to telnet to port 25 just disconnects me, or doesn't show the ESMTP greeting line.

The problem I am having is that I followed the directions exactly, and it worked the first time, and didn't work the second. I also re-installed my live server, and ran through the tutorial again, thinking I may have missed a step, but it still didn't work.

My config files look exactly like they do in the tutorial, and they also look the same as they do on my VMware server. SElinux is disabled.

If I disable SASL authentication in postfix, by entering postconf -e 'smtpd_sasl_auth_enable = no', then I can connect to the server and send a message successfully. However, I need SMTP authentication support, so I want to get this working.

I have looked through other forum posts, but everyone else's problems are different from mine. Can anybody offer an explanation?

Thanks,

Aaron Parecki
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5) sneaky_russian Installation/Configuration 4 26th September 2006 18:05
Virtual Users And Domains With Postfix, Courier And MySQL [+ procmail ?] immobilia HOWTO-Related Questions 5 29th June 2006 23:20
Virtual Users And Domains With Postfix, Courier And MySQL - "apt-get" and Courier burritonator HOWTO-Related Questions 3 15th March 2006 20:11
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 02:53
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 22:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.