Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 19th October 2006, 12:35
DreamState DreamState is offline
Junior Member
 
Join Date: Oct 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default The PHP binary coming with ISPConfig does not work properly on your system!

Hello,

I followed this excellent guide in order to setup a CentOS webserver for my school...

http://www.howtoforge.com/perfect_setup_centos_4.4

Everything went smoothly during the install and only two things didn't work - yum couldn't find ncftp and php-xml from the repos. I ignored this. I also did not do the zlib upgrade suggested in the final part after reading the comment from the CentOS-4 Lead Developer. In addition I installed Gnome (tut tut ). Everything worked ok. FTP and website, etc.

I then followed the guide to install ISPconfig, which I think should install straight onto the CentOS system (from the guide) and the install seemed to be going very smoothly. I answered all the initial questions, then the SSL questions. Apache went on ok and then I hit problems which I do not understand - sadly I am no expert at Linux (yet).

The first part of the log below is fine - I can re-run the config using the --disable-zlib-vcheck. However, I don't understand what the errors are that occur after this - do they all just occur due to the zlib error?

When I followed the CentOS guide it didn't install ClamAV to my knowledge but I assume that might be part of the install routine for ISPconfig? Anyway, any thoughts would be appreciated. I'm looking forward to getting this up and running.

Thanks for your time.

The log........

checking for zlib installation... /usr
configure: error: The installed zlib version may contain a security bug. Please upgrade to 1.2.2 or later: http://www.zlib.net. You can omit this check with --disable-zlib-vcheck but DO NOT REPORT any stability issues then!
ERROR: Could not configure ClamAV
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
./setup2: line 849: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! asyadiqin Installation/Configuration 19 7th August 2006 17:49
The PHP binary coming with ISPConfig does not work properly on your system! lykos Installation/Configuration 3 1st April 2006 07:53
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! xinefnarg Installation/Configuration 2 28th March 2006 16:45
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! max Installation/Configuration 6 13th January 2006 22:07


All times are GMT +2. The time now is 18:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.