Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 18th October 2006, 05:39
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default Help Forwarding Incoming Requests to Other Internal Machines (not the web server)

Hey all:

First off, I want to say that I am fairly well versed in computer hardware, networking, etc. but relatively new to Linux and very new to Web hosting. I just built a Web server, installed Fedora Core 5 and followed the excellent "How-To" on the "perfect setup." I now have ISPConfig installed and working great. Thanks to these excellent forums and some other great resources, I have my Web domain working just like I want it to.

The only thing left for me to do is to migrate one more thing from my Windows machine to my new Linux server so that the Windows machine can be shut down when not in use, and that is my setup for remote access to my TiVoWebPlus.

The way it is set up now, a incoming request to a certain domain (tivo1.xxxx.dyndns.com) is directed to my Windows machine. I have a program called OrenOSP (which as I understand it is based on Apache) set up to re-route these requests to my various TiVos (for instance, tivo1 would get rerouted to internal IP 192.168.1.121, and tivo 2 to .122, etc.). I know there has got to be a way to set up my Linux box to do this.

My first attempt was to simply set up co-domains where tivo1, tivo2, etc. were the hosts and were forwarded to 192.168.1.121, etc. While this works inside my network, it doesn't work remotely because, obviously, 192.168.1.121 is not an accessible IP from the outside world.

Any ideas as to how I would set this up? I only have one domain name, and would very much like to let my server handle these requests.

Thanks.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Webmail Relay Error palkat General 17 23rd April 2006 18:12
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 14:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.