Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 8th October 2006, 11:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,169
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

Your mail.log output is abit uncommon for ISPConfig. It seems that your psotfix configuration uses maildrop to deliver the emails, ISPConfig needs procmail.

Please post the content of your main.cf file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 8th October 2006, 14:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Also, the correct permissions for the web3_jhurt directory should be as follows:

Code:
drwxr-xr-x    4 web3_jhurt web3         4096  1. Okt 01:10 .
drwxr-xr-x    4 web3_jhurt web3         4096 15. Okt 2004  ..
-rw-r--r--    1 root     root          534 28. Dez 2005  .antivirus.rc
-rw-r--r--    1 root     root          772 28. Dez 2005  .autoresponder.rc
-rw-r--r--    1 root     root           22 28. Dez 2005  .bounce-exceed-quota.txt
-rw-------    1 web3_jhurt web3           24 28. Dez 2005  .forward
-rw-r--r--    1 root     root        67866 28. Dez 2005  .html-trap.rc
-rw-r--r--    1 root     root         3889 28. Dez 2005  .local-rules.rc
drwx------    5 web3_jhurt web3         4096 15. Okt 2004  Maildir
-rw-r--r--    1 root     root          175 28. Dez 2005  .mailsize.rc
-rw-r--r--    1 root     root          732 28. Dez 2005  .procmailrc
-rw-r--r--    1 root     root         2680 28. Dez 2005  .quota.rc
-rw-r--r--    1 root     root         1153 28. Dez 2005  .spamassassin.rc
-rw-r--r--    1 root     root         1641 28. Dez 2005  .user_prefs
-rw-r--r--    1 root     root            0 28. Dez 2005  .vacation.msg
drwxrwxr-x    2 web3_jhurt web3         4096 15. Okt 2004  web
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 10th October 2006, 05:14
meekish meekish is offline
Junior Member
 
Join Date: Sep 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great, I will track down the main.cf file and make sure those permissions are set correctly... *crossing my fingers*

Last edited by meekish; 10th October 2006 at 05:20.
Reply With Quote
  #14  
Old 10th October 2006, 05:27
meekish meekish is offline
Junior Member
 
Join Date: Sep 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Your mail.log output is abit uncommon for ISPConfig. It seems that your psotfix configuration uses maildrop to deliver the emails, ISPConfig needs procmail.

Please post the content of your main.cf file.
Here it is... How bad is it doc?

Code:
cat /etc/postfix/main.cf
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = reformationstudios.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = reformationstudios.com, localhost.com, , localhost
relayhost = 
mynetworks = 127.0.0.0/8
mailbox_command = 
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
  #15  
Old 11th October 2006, 10:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,169
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

looks fine so far. Which linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 12th October 2006, 00:53
meekish meekish is offline
Junior Member
 
Join Date: Sep 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dapper Drake. I followed the perfect server setup HOWTO for Dapper.
Reply With Quote
  #17  
Old 12th October 2006, 18:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Your main.cf looks ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 15th October 2006, 01:34
meekish meekish is offline
Junior Member
 
Join Date: Sep 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is there anything else I can check?
Reply With Quote
  #19  
Old 16th October 2006, 14:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please check the permissions of your user directories (see http://www.howtoforge.com/forums/sho...1&postcount=12 ). I guess you made a chown -R sometime.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 20th October 2006, 02:37
meekish meekish is offline
Junior Member
 
Join Date: Sep 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I ran a 'postfix check' and found out that I had accidentally chowned a bunch of files in /usr/lib/postfix. I chowned those back to root. However, 'postfix check' is still yielding the following warnings:

Code:
root@reformationstudios:/home/meekish# postfix check
postfix: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
postfix: warning: inet_protocols: configuring for IPv4 support only
postsuper: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
postsuper: warning: inet_protocols: configuring for IPv4 support only
postfix/postfix-script: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
postfix/postfix-script: warning: inet_protocols: configuring for IPv4 support only
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postqueue
postfix/postfix-script: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
postfix/postfix-script: warning: inet_protocols: configuring for IPv4 support only
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postdrop
How would I go about fixing those?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
re:perfect setup ubuntu 6.06 - email setup when not using ispconfig caffine_fizz HOWTO-Related Questions 5 19th August 2006 20:05
email setup shiidii Installation/Configuration 2 2nd August 2006 11:39
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 20:58
Postfix or email server setup matrich Server Operation 3 24th November 2005 22:26


All times are GMT +2. The time now is 12:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.