Prev Previous Post   Next Post Next
  #1  
Old 18th September 2006, 07:10
rbartz rbartz is offline
Member
 
Join Date: Apr 2006
Posts: 80
Thanks: 9
Thanked 6 Times in 5 Posts
Default suEXEC problem

I turned on suEXEC today, and tried the test script, test.pl in the cgi-bin directory. It returned 500 server errors. When I looked in /var/log/httpd/suexec.log I found:

[2006-09-17 21:13:44]: directory is writable by others: (/var/www/web35/cgi-bin)
[2006-09-17 21:13:40]: uid: (10074/richard1) gid: (10038/10038) cmd: test.pl

ll of the ..../web38 dir gave
drwxrwxr-x 2 richard1 web38 4096 Sep 17 21:17 cgi-bin

By chmoding the cgi-bin from 0775 to 0755 the problem is solved, the script runs without error.

The directory is owned by the user and group. I see that suEXEC will not run if the directory is owned by any other, but that is not the case. Surely someone has run into this.

If I change the permissions on the cgi-bin will they stay at 755? Why are they 775 to begin with, does ispConfig have some reason for this?

Thanks

RDB
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56


All times are GMT +2. The time now is 12:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.