Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 6th September 2006, 15:05
dfriis dfriis is offline
Junior Member
 
Join Date: Feb 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Web server offline after php4 and apache2 upgrade

I wanted to upgrade the apache and php version on my debian sarge installation and followed the instructions at http://www.howtoforge.com/forums/sho...=upgrade+mysql

I didn't change the file sources.list though, I just did an apt-get update first to check if there were any updates for me, and there was.

I'm not sure what it did upgrade though but when I try to start apache I get:

Code:
www:/var/log/httpd# /etc/init.d/apache2 restart
Forcing reload of web server: Apache2 ... failed!
You may still have some apache2 processes running.  There are
processes named 'apache2' which do not match your pid file,
and in the name of safety, we've left them alone.  Please review
the situation by hand.
Syntax error on line 48 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps mis-spelled or defined by a module not included in the server configuration
The only thing I wrote was:
Code:
apt-get update
apt-get install mysql-server mysql-client libmysqlclient12-dev
apt-get install apache2 apache2-doc
apt-get install libapache2-mod-php4 libapache2-mod-perl2 php4 php4-cli php4-common php4-curl php4-dev php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear php4-xslt curl libwww-perl imagemagick
I've searched the forums for a while now and the only problem I think I might have is that mod_php isn't loaded. Why is that setting lost and how can I fix it?

I'm not that confident around apache, php and linux but I'm good at following instructions. It's just a pain in the behind that everything gets messed up as soon as you try to use this friggin' system...

Please help me, this server is in some sort of production and I have to get it up and running
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Apache2 With PHP5 And PHP4 At The Same Time hansmi HOWTO-Related Questions 3 28th June 2006 10:49
php4 as CGI and php5 as Apache2 Handyman HOWTO-Related Questions 1 7th June 2006 05:29
Apache2 with PHP4 and PHP5 on Debian Sarge chazaq HOWTO-Related Questions 1 28th March 2006 20:42


All times are GMT +2. The time now is 04:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.