Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 3rd September 2006, 23:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by jjw
netstat -tap:
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:imaps                     *:*                         LISTEN      2002/xinetd
tcp        0      0 *:32769                     *:*                         LISTEN      1670/rpc.statd
tcp        0      0 *:pop3s                     *:*                         LISTEN      2002/xinetd
tcp        0      0 *:mysql                     *:*                         LISTEN      2093/mysqld
tcp        0      0 *:pop3                      *:*                         LISTEN      2002/xinetd
Aren't you using Maildir? Then you should run Dovecot instead of your xinetd based POP3/IMAP daemon... Your current POP3/IMAP daemon uses mbox.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 4th September 2006, 01:29
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Aren't you using Maildir? Then you should run Dovecot instead of your xinetd based POP3/IMAP daemon... Your current POP3/IMAP daemon uses mbox.
Hello Falko, and thanks to you for helping me (as well as the How To's and The Forum).

The error I got was *before* I switched over to Maildir. Why did I get that message before I switched over to Maildir format?

Your suggestion worked (surprise).

I've stopped xinetd and started dovecot (actually, I had to remove the 0.99 version and install the 1.0 version which allows for character translation with the 'auth_username_translation =' directive). I've been able to send email from behind the network, and I'll check for remote authentication as soon as I get to a remote machine.

I'll add more when I get the results.

~jjw
Reply With Quote
  #13  
Old 4th September 2006, 02:02
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ouch. I got the message from my mail client that "Server Does Not Support Secure Authentication. This was from the LAN, and trying to use SSL & Seucre Authentication. Client is Thunderbird 1.0.2
Reply With Quote
  #14  
Old 4th September 2006, 02:05
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ouch. I just tried using Thunderbird 1.0.2 and got the "Server Does Not Support Secure Authentication" message.

Here is what I get when I telnet localhost 25:

Code:
250-mail.wnetworks.net
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
Reply With Quote
  #15  
Old 4th September 2006, 08:55
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I just realized that I didn't need the 'auth_username_translation =' directive, so I did a reinstall to get back to the 'perfect install', and utilizing Falko's suggestion to use Dovecot with Maildir.

I'm hanging on SMTP AUTH it seems.
Reply With Quote
  #16  
Old 4th September 2006, 11:18
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

Quote:
Originally Posted by jjw
Well, I just realized that I didn't need the 'auth_username_translation =' directive, so I did a reinstall to get back to the 'perfect install', and utilizing Falko's suggestion to use Dovecot with Maildir.

I'm hanging on SMTP AUTH it seems.
Please post the output of "netstat -tap" and check your postfix master.cf file that TLS is enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 4th September 2006, 14:37
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Please post the output of "netstat -tap" and check your postfix master.cf file that TLS is enabled.
Thank you Till. Here is the relevant output:

netstat -tap
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:imaps                     *:*                         LISTEN      4100/xinetd
tcp        0      0 *:32769                     *:*                         LISTEN      1651/rpc.statd
tcp        0      0 *:pop3s                     *:*                         LISTEN      4100/xinetd
tcp        0      0 *:mysql                     *:*                         LISTEN      5245/mysqld
tcp        0      0 *:pop3                      *:*                         LISTEN      4100/xinetd
tcp        0      0 *:imap                      *:*                         LISTEN      4100/xinetd
tcp        0      0 *:sunrpc                    *:*                         LISTEN      1633/portmap
tcp        0      0 *:81                        *:*                         LISTEN      28766/ispconfig_htt
tcp        0      0 mail.wnetworks.net:domain   *:*                         LISTEN      28886/named
tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      28886/named
tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      1960/cupsd
tcp        0      0 localhost.localdomain:5335  *:*                         LISTEN      1942/mDNSResponder
tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      28886/named
tcp        0      0 *:smtp                      *:*                         LISTEN      28861/master
tcp        0      0 *:http                      *:*                         LISTEN      28789/httpd
tcp        0      0 *:ftp                       *:*                         LISTEN      28902/proftpd: (acc
tcp        0      0 *:ssh                       *:*                         LISTEN      2020/sshd
tcp        0      0 *:https                     *:*                         LISTEN      28789/httpd
# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 mail.wnetworks.net ESMTP Postfix
ehlo localhost
250-mail.wnetworks.net
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
main.cf:
Code:
queue_directory = /var/spool/postfix

command_directory = /usr/sbin

daemon_directory = /usr/libexec/postfix

mail_owner = postfix


inet_interfaces = all


unknown_local_recipient_reject_code = 550


alias_maps = hash:/etc/aliases

alias_database = hash:/etc/aliases
debug_peer_level = 2


debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5


sendmail_path = /usr/sbin/sendmail.postfix

newaliases_path = /usr/bin/newaliases.postfix

mailq_path = /usr/bin/mailq.postfix

setgid_group = postdrop

html_directory = no

manpage_directory = /usr/share/man

sample_directory = /usr/share/doc/postfix-2.2.2/samples

readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Why is it that I have to rebuild the certificates *after* the install process after a fresh os/ispcoinfig install? I always get the 8182 error (except one time).
Reply With Quote
  #18  
Old 4th September 2006, 14:44
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the output from another machine:

$ telnet mail.wnetworks.net 25
Code:
Trying 192.168.0.10...
Connected to mail.wnetworks.net.
Escape character is '^]'.
220 mail.wnetworks.net ESMTP Postfix
ehlo http.wnetworks.net
250-mail.wnetworks.net
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
Reply With Quote
  #19  
Old 4th September 2006, 15:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by jjw
Why is it that I have to rebuild the certificates *after* the install process after a fresh os/ispcoinfig install? I always get the 8182 error (except one time).
Because you enter invalid information when you create the certificates the first time. Accept the default values. The most common error is this: when you're asked for the "common name (e.g., your name)", this doesn't mean your personal name, but your domain name (e.g. example.com).

Quote:
I'm hanging on SMTP AUTH it seems.
Please add
Code:
mynetworks = 127.0.0.0/8
to /etc/postfix/main.cf and restart Postfix. Then try to send a mail over that server with your email client (without SSL, but with "Server requires authentication." enabled).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 4th September 2006, 15:36
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thank you Falko.

Quote:
Originally Posted by falko
Because you enter invalid information when you create the certificates the first time. Accept the default values. The most common error is this: when you're asked for the "common name (e.g., your name)", this doesn't mean your personal name, but your domain name (e.g. example.com).
Ok, I thought I did it right. Anyway, I entered the same info the second time around.

Quote:
Originally Posted by falko
Please add
Code:
mynetworks = 127.0.0.0/8
to /etc/postfix/main.cf and restart Postfix. Then try to send a mail over that server with your email client (without SSL, but with "Server requires authentication." enabled).
I did this. I then attempted to connect from my mail client. I just timed out. No messages anywhere. I then logged in from another machine on the command line port 110, and then I logged in as the user, but it didn't list any messages, even though I have another screen open that shows a file in /var/www/web1/user/web1_test4/Maildir/new. This seems odd indeed.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5 graphical install rlhesson Installation/Configuration 2 14th August 2006 17:00
quota question on perfect install fedora core 5.0 bmayock HOWTO-Related Questions 7 6th July 2006 13:20
Regarding the Fedora Core 5 Perfect Install - Quota EricS HOWTO-Related Questions 4 30th May 2006 04:21
Fedora Core 5 x64 Perfect Install Question? gjcomputer Installation/Configuration 1 26th April 2006 09:27
Fresh Install of FC4 using Perfect Install HowTo latcarf HOWTO-Related Questions 21 10th August 2005 22:55


All times are GMT +2. The time now is 13:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.