#1  
Old 9th October 2005, 03:25
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default PHP version...

I currently have PHP 5.0.5 installed for ISPConfig. I am running another application (phpBB2) on my server and it requires a version below 5.x. Does anyone see any issues on downgrading? Anything I need to be concerned with in ISPConfig?
Sponsored Links
  #2  
Old 9th October 2005, 12:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
Default

ISPConfig works with PHP4 as well as with PHP5. I think you will not get any issues with ISPConfig.
  #3  
Old 9th October 2005, 17:27
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

When I remove the php 5.0.5 version, it is not going to remkove any shared files used by ISPConfig is it? Or, would it be better to just install the 4.x version over top?
  #4  
Old 9th October 2005, 17:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
Default

There are no shared files, ISPConfig has its own PHP5 installation for the controlpanel backend so it is not affected by the change of the PHP installation for the websites.

I recommend to first remove the PHP5 before installing PHP4.
  #5  
Old 9th October 2005, 18:29
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

I think I may have found an underlying problem...

I was going to use the 'Add/Remove Applications' in the GNome desktop (since I am not that comfotable with the terminal yet). When I unchecked 'php' package and continued to 'Update' it came up with the following error:

Unlocatable package:
php
Required by:
('php-pear', '5.0.5', '2.1')
('php-ldap', '5.0.5', '2.1')
('php-devel', '5.0.5', '2.1')
('php-gd', '5.0.5', '2.1')
('php-imap', '5.0.5', '2.1')
('php-mysql', '5.0.5', '2.1')
('php-odbc', '5.0.5', '2.1')
('php-xmlrpc', '5.0.5', '2.1')
  #6  
Old 15th October 2005, 22:58
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

I am still having issues on downgrading my PHP 5.0.5 version. So ISPConfig has its own instance of PHP5. With that in mind, I tried installing PHP 4.4.0 on my system, but the installation instructions on the PHP website directed me to install Apache 2 along with it. I wen on with the install and everything seemed okay.

When I did:
Code:
php -v
it replied with:
Code:
PHP 5.0.5 (cli) (built: Sep  8 2005 06:58:48)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.5, Copyright (c) 1998-2004 Zend Technologies
Now I am confused...shouldn't it be 4.4.0?

Back to my original problem (PHPBB2 requires < PHP 5.x). When I am trying to install PHPBB2 for one of my ISPConfig sites, is there something special that I need to do to get it to use my PHP 4.4.0 version?

Would it just be easier to downgrade my ISPConfig PHP instance to 4.4.0? What is involved in that?

Thanks for any help you can offer...
  #7  
Old 15th October 2005, 23:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by ctroyp
Now I am confused...shouldn't it be 4.4.0?
Run
Code:
updatedb
locate php
to find out if you have more than one PHP installation (besides the ISPConfig PHP, of course). Maybe your PHP 4 saw that there is already a PHP 5 and chose to install itself somewhere else.

Quote:
Originally Posted by ctroyp
Would it just be easier to downgrade my ISPConfig PHP instance to 4.4.0? What is involved in that?
No, because the ISPConfig PHP is not used by your main Apache. This is something completely different.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #8  
Old 15th October 2005, 23:53
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

All I could find is 4.4.0?

Shouldn't 5.0.5 show up somewhere?
  #9  
Old 16th October 2005, 00:32
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by falko
Code:
Quote:
Originally Posted by ctroyp
Would it just be easier to downgrade my ISPConfig PHP instance to 4.4.0? 
What is involved in that?
No, because the ISPConfig PHP is not used by your main Apache. This is something completely different.
If I am installing PHPBB2 for one of my ISPConfig hosted sites, the PHPBB2 directory needs to be located in the respective web directory of the site. Since ISPConfig uses PHP 5.0.5, won't PHPBB2 try and use it also?
  #10  
Old 16th October 2005, 02:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by ctroyp
If I am installing PHPBB2 for one of my ISPConfig hosted sites, the PHPBB2 directory needs to be located in the respective web directory of the site. Since ISPConfig uses PHP 5.0.5, won't PHPBB2 try and use it also?
No, because ISPConfig has its own Apache. There are two Apaches on your system: your main one running on port 80 (and maybe 443) which uses its own PHP, and the ISPConfig Apache on port 81 using another PHP. These two are totally independent of each other.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[error] an unkown filter was not added: PHP Arien Installation/Configuration 12 7th October 2006 14:17
PHP not working jefash General 10 28th May 2006 08:48
Cannot compile new PHP with apxs olli Installation/Configuration 11 4th March 2006 15:32
Multiple domains jysse Installation/Configuration 2 10th August 2005 11:22
Apache + PHP lola Server Operation 1 25th April 2005 13:41


All times are GMT +2. The time now is 19:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.