#11  
Old 27th July 2005, 12:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

So you simply changed the php-5.0.4 sources and the compile script and ran ./setup again? Did php compile without errors then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 22nd August 2005, 15:14
dhark01 dhark01 is offline
Junior Member
 
Join Date: Aug 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Angry I still have problems installing

Hi there!

After applying the hints i found in this thread i stil get the following message:

/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.5/../../../../x86_64-suse-linux/bin/ld: /root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32S against `ssl2_accept' can not be used when making a shared object; recompile with -fPIC
/root/ispconfig/openssl/lib/libssl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
ERROR: Could not make PHP

Can somebody help?

Thanks in advance,

Kind regards,

dhark01
Reply With Quote
  #13  
Old 28th August 2005, 17:09
gbjbaanb gbjbaanb is offline
Junior Member
 
Join Date: Aug 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi. I have this too: I'm running CentOS 4.1, 64-bit.

The first error I got was unable to link with libmysqlclient. I think I fixed this by installing mysql-devel but I may also have edited the lib path to /usr/lib64 as well. I can't remember so I'll have to report back on this when I next install on a clean system.

The second error:
Code:
/root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32S against `ssl2_accept' can not be used when making a shared object; recompile with -fPIC
was solved by removing reference to the ISPConfig-supplied openssl. This may be an issue with the compile options for the ispconfig-supplied openssl, but if openssl is supplied with the distro, I see no need to recompile it.

Either way, 'srg' got it right by editing compile_aps/compile and changing the PHP directive "--with-openssl=$(INSTALL_ROOT)/openssl" to "--with-openssl"
I do have openssl-devel installed in case you need this.
Reply With Quote
  #14  
Old 28th August 2005, 18:03
gbjbaanb gbjbaanb is offline
Junior Member
 
Join Date: Aug 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Smile

Last 2 items I had to do for centos install, install clamav via yum, and update zlib to v1.2.3 (the latest as of writing).

So, if we can make these changes to the installer, I will install my server from the DVD, and start again from clean to test it properly.
Reply With Quote
  #15  
Old 27th September 2005, 21:26
lodac lodac is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

did anyone get a fix to this problem..

I am running X86_64 suse 9.3 trying to install ISPconfig
Reply With Quote
  #16  
Old 27th September 2005, 21:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,451
Thanks: 813
Thanked 5,221 Times in 4,092 Posts
Default

Have you installed the ssl devel packages from suse and point the configure statements in the ISPConfig compile script to the ssl sources from suse?
Reply With Quote
  #17  
Old 27th September 2005, 22:41
lodac lodac is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay I installed the ssl-devel

I edited the configure to

./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl=/usr/include/openssl --with-mysql=/usr --disable-libxml

and just --with-openssl

and I ran into
configure: error: Cannot find OpenSSL's <evp.h>
Reply With Quote
  #18  
Old 27th September 2005, 22:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,451
Thanks: 813
Thanked 5,221 Times in 4,092 Posts
Default

You can try to compile it with the parameter "--with-openssl" without specifying a path. See also: http://www.howtoforge.com/forums/sho...0&postcount=12

If this wont help, try to find the file evp.h (with e.g. locate, dont forget to run updatedb first) and correct the path to openssl.
Reply With Quote
  #19  
Old 8th October 2005, 21:00
gbjbaanb gbjbaanb is offline
Junior Member
 
Join Date: Aug 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default CentOS 4.1 64bit

OK. I trashed my old ISPConfig install and installed v2.09.

It recognises CentOS 4.1 64bit now, but it still does not compile.

To get installed, you will need to install the ssl-devel package.

Then you will need to edit the compile script (in compile_aps directory) to use the local openssl libraries, and the 64-bit zlib libraries:
Code:
cd ../${PHP}
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
then, you need to follow the steps described here: http://www.howtoforge.com/forums/sho...0&postcount=12 to get around the mysql bug.

Code:
Before starting the installtion process do this, because mysql has a bug in the x86_64 which can only be fixed so.
mkdir /usr/local/lib/mysql
and create symlinks "include" and "lib" pointing to the original directories (here /usr/include/mysql and /usr/lib64/mysql)
cd /usr/local/lib/mysql
ln -s /usr/include/mysql include
ln -s /usr/lib64/mysql lib
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.