Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 14th August 2006, 17:59
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default server reached MaxClient settings, consider raising the MaxClients setting

My Apache2 sometimes gets really slow..

Looking at the log file it's showing server reached MaxClient settings, consider raising the MaxClients setting at the times apache is slow, so I guess that this is causing the slowdown.

After some googling I found this.

The problem now is that I do not have MaxClients in the /etc/apache2/httpd.conf , but I do have it in /etc/apache2/apache2.conf

In apache2.conf I have to times a MaxClients!

Code:
<IfModule prefork.c>
StartServers 50
MinSpareServers 50
MaxSpareServers 200
MaxClients 256
MaxRequestsPerChild 1
</IfModule>

<IfModule worker.c>
StartServers         2
MaxClients         150 
MinSpareThreads     25
MaxSpareThreads     75
ThreadsPerChild     25
MaxRequestsPerChild  0
</IfModule>

Do I need to set both MaxClients, or do I need to add a MaxClients to the httpd.conf?

Also. The server (Debain Sarge 3.1) has 4GB of memory.. Will a MacClients of lets say 1000 be okay?

Last edited by edge; 14th August 2006 at 18:19.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Webmail Relay Error palkat General 17 23rd April 2006 19:12
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 11:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 07:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.