Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th August 2006, 19:38
crn_admin crn_admin is offline
Junior Member
 
Join Date: Aug 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default MySQL related Installation Problem

Hello all,

I have run into a stumbling block in my installation of ISPConfig and I am hoping somebody can help.

I have done everything as described in "The Perfect Setup" guide for SUSE.... the only complication being that I am running SUSE 10.0, not 9.3. However, all seemed to be going exactly according to plan until I attempted to install ISPConfig itself. The entire installation seems to run normally, but the last bit of output from the compilation indicated there was a problem:

/root/ispconfig/httpd/bin/apachectl startssl: httpd started
Could not connect to MySQL server!FreshClam is already running!
ISPConfig system is now up and running!

When I try to log into ISPConfig via browser, I get this:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60

I am not sure what the problem is. MySQL is up and running and I am able to log into it.... I am even able to log in remotely. One odd thing seems to be that, while the database for ISPConfig is created in MySQL, there are no tables in it... a completely empty schema.

Any help would be greatly appreciated!

Sean
Reply With Quote
Sponsored Links
  #2  
Old 9th August 2006, 16:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Does your MySQL root password contain uncommon characters? That is most likely the problem.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 9th August 2006, 16:47
crn_admin crn_admin is offline
Junior Member
 
Join Date: Aug 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

By uncommon, do you mean non-alphanumeric? The root pw does contain '@' and '$'.
Reply With Quote
  #4  
Old 9th August 2006, 17:22
crn_admin crn_admin is offline
Junior Member
 
Join Date: Aug 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I changed the MySQL root pw to contain only alpha-numeric characters and re-installed. This time, I got the following output at the end of the install process:

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!FreshClam is already running!
ISPConfig system is now up and running!

Again, the database has been created, but there are no tables in the schema. When I attempt to log in to ISPConfig through the web interface, I get the message that the password (admin) is invalid.

Any thoughts?
Reply With Quote
  #5  
Old 10th August 2006, 17:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by crn_admin
I changed the MySQL root pw to contain only alpha-numeric characters and re-installed.
Did you delete the old ISPConfig before you did this? Otherwise the installer performs an update, and if your database was empty before, it willl be empty after the update...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 10th August 2006, 19:03
crn_admin crn_admin is offline
Junior Member
 
Join Date: Aug 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

That did the trick... thanks a lot!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
MySQL installation roblem [/me sad] Nejko Installation/Configuration 16 11th January 2006 13:28
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
Installation problem xma Installation/Configuration 15 26th September 2005 13:22


All times are GMT +2. The time now is 08:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.