Prev Previous Post   Next Post Next
  #1  
Old 7th August 2006, 22:01
AndyF AndyF is offline
Junior Member
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't send External Mail

I think i've gone round and round in circles the last couple of days with this, so i offer it up to other peoples advice.

Ubuntu 6.06 LTS, following Perfect install (mostly) - installed as LAMP server.

I've managed to get everything working except for emails outbound to external addresses.

Trying to send from andy@friar.info -> andy@novus.co.uk

Postfix main.cfg

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

append_dot_mydomain = no

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

myhostname = woody.friar.info
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = woody.friar.info, localhost.friar.info, , localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names


Mail Logs

Aug 7 20:42:04 woody postfix/smtpd[6438]: connect from unknown[192.168.1.10]
Aug 7 20:42:04 woody postfix/smtpd[6438]: NOQUEUE: reject: RCPT from unknown[192.168.1.10]: 554 <andy@novus.co.uk>: Relay access denied; from=<andy@friar.info> to=<andy@novus.co.uk> proto=ESMTP helo=<p4>
Aug 7 20:42:04 woody postfix/smtpd[6441]: connect from unknown[192.168.1.10]

Outlook logs

2006.08.07 20:42:01 SMTP (192.168.1.15): Connected to host
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 220 woody.friar.info ESMTP Postfix (Ubuntu)
2006.08.07 20:42:01 SMTP (192.168.1.15): [tx] EHLO p4
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-woody.friar.info
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-PIPELINING
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-SIZE 10240000
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-VRFY
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-ETRN
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-STARTTLS
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-AUTH LOGIN PLAIN
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250-AUTH=LOGIN PLAIN
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250 8BITMIME
2006.08.07 20:42:01 SMTP (192.168.1.15): Authorizing to server
2006.08.07 20:42:01 SMTP (192.168.1.15): [tx] AUTH LOGIN
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 334 VXNlcm5hbWU6
2006.08.07 20:42:01 SMTP (192.168.1.15): [tx] YW5keQ==
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 334 UGFzc3dvcmQ6
2006.08.07 20:42:01 SMTP (192.168.1.15): [tx] *****
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 235 Authentication successful
2006.08.07 20:42:01 SMTP (192.168.1.15): Authorized to host
2006.08.07 20:42:01 SMTP (192.168.1.15): Connected to host
2006.08.07 20:42:01 SMTP (192.168.1.15): [tx] MAIL FROM: <*****>
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 250 Ok
2006.08.07 20:42:01 SMTP (192.168.1.15): [tx] RCPT TO: <*****>
2006.08.07 20:42:01 SMTP (192.168.1.15): <rx> 554 <*****>: Relay access denied
2006.08.07 20:42:01 SMTP (192.168.1.15): End execution


To me this is saying that outlook is authenticated correctly but the destination isn't allowed?

Anyone any advice?

Thanks

Andy
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
How to setup external mail servers? mxc Installation/Configuration 1 16th July 2006 12:39
send and receve mail on centos 4.3 tesquenure Installation/Configuration 11 25th April 2006 21:15
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47
Can't get MX for external mail server to work semmelbroesel Installation/Configuration 4 25th November 2005 17:48


All times are GMT +2. The time now is 00:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.