Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 7th August 2006, 13:33
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default permissions problem on the /var/www/webXX folders

hi there,

I just commited a big mistake: I was trying to get a plugin for a thirdparty app running which needed certain permissions on the /var/www/web1 folder.

what I did without thinking was this: chown -R web1_postmaster:www-data /var/www/web1 and chmod -R 755 /var/www/web1

now I realized that my permissions are totally borked, my 2 users inside this site cannot read their emails etc.

how can I undo this mess as fast as possible?

p.s. I have a backup from this morning done with ftplicity, so I tried ftplicity fetch var/www/web1 /var/www 1D but it just tells me it cannot overwrite. I tried fetch var/www/web1 /var/www/bckp 1D and then copied all folders and files over with the result, that the main user can login and read mails while the other user cannot even login, he gets this error: ERROR: Connection dropped by IMAP server

any clues, please

###edit###
basically I chowned user:group the user directories (including the subdirectories) and mail is working now.
anything else that could need fixing?

Last edited by Ovidiu; 7th August 2006 at 13:43.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 17:06
ISPConfig Folders Link Problem sodapop General 3 10th January 2006 13:28


All times are GMT +2. The time now is 20:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.