Prev Previous Post   Next Post Next
  #1  
Old 2nd August 2006, 03:03
shiidii shiidii is offline
Member
 
Join Date: Jul 2006
Location: Melbourne, Australia
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default email setup

Ok I think I may have muddled things up
I have ispconfig installed, but something gave me the notion that the Mail service wouldn't work, so I also went through with this flurdy tutorial and set up my mail server as such:
http://flurdy.com/docs/postfix/index.html

So, courier is pointed to these mysql databases in order to search for these usernames. Everything is synchronized with that tutorial.
But I am able to log in with my ISPconfig email addresses in outlook express,
and emails aren't coming IN. When sending emails TO the ispconfig emails, I get the response "user unknown"

Here's my Main.cf in postfix

Code:
myhostname = mail.mydomain.com
alias_maps = hash:/etc/postfix/aliases
alias_database = hash:/etc/postfix/aliases
myorigin = /etc/mailname
mydestination =
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
inet_protocols = all
smtpd_sasl_local_domain = no
smtpd_sasl_auth_enable = no
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

# modify the existing smtpd_recipient_restrictions
smtpd_recipient_restrictions = reject_unauth_pipelining, permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_recipient, reject_unauth_destination, check_policy_service inet:127.0.0.1:60000, permit
I'm sure my changes have messed up the incoming mail resolving. Is there a guide that I can follow to setup postfix/courier to read ispconfig's user emails and not look the ones I setup?

Last edited by shiidii; 2nd August 2006 at 03:07.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Setup Email Configuration problems jerutley Installation/Configuration 2 12th June 2006 22:06
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 20:58
Email Setup Question g8rbait Server Operation 4 4th December 2005 11:41
Postfix or email server setup matrich Server Operation 3 24th November 2005 22:26


All times are GMT +2. The time now is 20:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.