Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st July 2005, 14:19
BigB BigB is offline
Junior Member
 
Join Date: Jul 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Fail to open ISPConfig site: firefox 8182

It complains about my certificate being invalid, how can I fix this?

IE doesnt open at all

My setup using debian and the howto at http://www.falkotimme.com/howtos/per..._debian_sarge/

worked great until now...

Help please
Reply With Quote
Sponsored Links
  #2  
Old 21st July 2005, 14:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Is ISPConfig running? Execute

Code:
netstat -tap
and look if ISPConfig is running on port 81. If not, restart ISPConfig:
Code:
/etc/init.d/ispconfig_server restart
BTW, you did try to connect on port 81, didn't you (it's https://url_of_your_server:81)?

It's also possible that the firewall on your desktop is blocking access to port 81. Shut down your firewall and try again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st July 2005, 14:45
BigB BigB is offline
Junior Member
 
Join Date: Jul 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes it is running, however the certificates the setup generated seem to be faulty, is there a way to restart that part of the setup or an other way to re-generate those certificates?
Reply With Quote
  #4  
Old 21st July 2005, 15:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Try this:

Code:
openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key
Restart ISPConfig afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following 13 Users Say Thank You to falko For This Useful Post:
awd.pt (18th July 2008), banancanard (26th March 2008), CaptainBalou (5th September 2007), CPU_Lizard (9th October 2008), docdries (2nd August 2008), jkrell (30th March 2008), linus (3rd December 2008), lubos (28th November 2007), Morons (30th April 2007), odcheck (3rd August 2009), oriongr (27th February 2008), swggy (11th May 2007), webcycler (29th April 2008)
  #5  
Old 9th August 2005, 18:15
m u r m u r is offline
Senior Member
 
Join Date: Jul 2005
Posts: 152
Thanks: 13
Thanked 1 Time in 1 Post
Send a message via AIM to m u r Send a message via MSN to m u r
Default

Well, firefox at least gives me the option now. It still says, "This certificate is not in the trusted root database." Is that normal?
Reply With Quote
  #6  
Old 9th August 2005, 18:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Quote:
Originally Posted by m u r
Well, firefox at least gives me the option now. It still says, "This certificate is not in the trusted root database." Is that normal?
Yes, because it is an self signed certificate. If you dont want to have this messgae you must buy an SSL Certificate from an SSL Authority.
Reply With Quote
  #7  
Old 13th August 2005, 05:56
KenMcGinnis KenMcGinnis is offline
Junior Member
 
Join Date: Aug 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to remove SSL from port 81.

I have the SSL working for port 81, admin console, no problem. However, I want to have a cert on port 80 (192.168.0.195:80) but I can't because there already is a cert for that IP. How to remove the https: access and use http: ?
Reply With Quote
  #8  
Old 13th August 2005, 11:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Quote:
Originally Posted by KenMcGinnis
I have the SSL working for port 81, admin console, no problem. However, I want to have a cert on port 80 (192.168.0.195:80) but I can't because there already is a cert for that IP. How to remove the https: access and use http: ?
change the file /root/ispconfig/httpd/conf/httpd.conf and the Server URL in the ispconfig configuration in /home/admispconfig/ispconfig/lib/config.inc.php

When you switch the controlpanel httpd to port 80, you must have an IP only for the controlpanel httpd and configure the admin server to only to listen to that IP. And your main apache server must be configured to listen on all IP's except the IP from the controlpanel httpd.
Reply With Quote
  #9  
Old 14th November 2005, 23:19
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by till
If you dont want to have this message you must buy an SSL Certificate from an SSL Authority.
Is there a step-by-step description of how to install a bought certificate into a working ISPConfig setup?

I'm thinking about the certificate for the Admin login, not the public server.
Reply With Quote
  #10  
Old 14th November 2005, 23:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

http://www.instantssl.com/ssl-certif...ate-index.html

The "Certificate Signing Request" is /root/ispconfig/httpd/conf/ssl.csr/server.csr, the certificate is /root/ispconfig/httpd/conf/ssl.crt/server.crt.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.