Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 16th July 2006, 21:22
chrisc chrisc is offline
Junior Member
 
Join Date: Jul 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix refusing smtp connections

Hi there,

The HDD in my server failed the other day, so I though I'd take the opportunity to give ISPConfig a go.

I followed the Ubuntu 6.06 HOWTO but seem to have been left with a setup where Postfix refuses any incoming connections on Port 25.

I'm sure I'm missing something obvious, but for the life of me can't see what.

Here's my postfix conf:
Code:
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no
append_dot_mydomain = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
myhostname = hub.chriscole.info
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = hub.chriscole.info, localhost.chriscole.info, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
Firewall is off (and iptables -L is empty).

From the server itself, telnet localhost 25 with ehlo localhost gives:
Code:
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 hub.chriscole.info ESMTP Postfix (Ubuntu)
ehlo localhost
250-hub.chriscole.info
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
When I try to connect on Port 25 from 'remote' machine (this box is not currently connected to the internet, so it's just another machine behind a switch setup on the same subnet), nothing gets recorded in /var/log/mail.log - only error the client sees is "connection refused"

Any suggestions would be much appreciated,

Chris.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
IMAP question - Moving servers and mail. Brenton Installation/Configuration 11 14th May 2010 14:38
Postfix smtpd_banner lehadi Server Operation 7 15th May 2006 17:14
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20
postfix problem flourishing General 1 7th December 2005 17:39


All times are GMT +2. The time now is 13:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.