#1  
Old 3rd July 2006, 13:33
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default Postfix IPV4 0r IPV6?

I have postfix running with tls enabled now I want to disable IPV6 if I do this then these warning messages appear.

postfix/sendmail[5824]: warning: inet_protocols: IPv6 support is
disabled: Address family not supported by protocol
postfix/postdrop[5827]: warning: inet_protocols: IPv6 support is
disabled: Address family not supported by protocol
postfix/cleanup[5830]: warning: inet_protocols: IPv6 support is
disabled: Address family not supported by protocol
postfix/anvil[5483]: warning: inet_protocols: IPv6 support is disabled:
Address family not supported by protocol


In the main.cf flie it reads:

inet_interfaces = all

If I change this to

inet_interfaces = IPV4

will this solve the above warning? and is it ok to use IPV4?



finally where do i enable relaying in postfix? (ie:mail client relaying via smtp from a diffrent machine-win server)
there are only two machines altogether on the network).

mynetworks=127.0.0.1/8 (at the moment) the ip address of win machine is 192.168.1.10 so how to change
my networks to enable relaying?


hotchilli

Last edited by hotchilli; 3rd July 2006 at 22:41.
Reply With Quote
Sponsored Links
  #2  
Old 3rd July 2006, 23:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by hotchilli
I have postfix running with tls enabled now I want to disable IPV6 if I do this then these warning messages appear.

postfix/sendmail[5824]: warning: inet_protocols: IPv6 support is
disabled: Address family not supported by protocol
postfix/postdrop[5827]: warning: inet_protocols: IPv6 support is
disabled: Address family not supported by protocol
postfix/cleanup[5830]: warning: inet_protocols: IPv6 support is
disabled: Address family not supported by protocol
postfix/anvil[5483]: warning: inet_protocols: IPv6 support is disabled:
Address family not supported by protocol
What's the output of

Code:
postconf -d|grep inet_protocols
and
Code:
postconf -n|grep inet_protocols
?
Why do you want to disable it? It doesn't hurt to have it...

Quote:
Originally Posted by hotchilli
finally where do i enable relaying in postfix? (ie:mail client relaying via smtp from a diffrent machine-win server)
there are only two machines altogether on the network).
Have a look here: http://www.howtoforge.com/forums/sho...ight=relayhost
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th July 2006, 21:23
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default

falko wrote:

>?
>why do you want to disable it? It doesn't hurt to have it.

yes good question. lets leave it.

thanks for the url re postfix relaying but at the moment my set up
is maybe a little diffrent to the normal set up i have
smtpd_tls_auth_only = yes

so what else is avaliable ? only url I could find was this
http://www.postfix.org/access.5.html

As I see it there are two ways around this, the easy way which might not work (ie)

mynetworks = 192.168.1.10/32, 127.0.0.1/8

where 192.168.1.10 is the static ip address of the win server.

OR

the not so easy way:

smtpd_client_restrictions =
permit_mynetworks,
...
...
smtpd_sender_restrictions =
permit_mynetworks,
...
...
smtpd_recipient_restrictions =
permit_mynetworks,

"check_client_access hash:/etc/postfix/access"
for "permit_mynetworks".

Create the file /etc/postfix/access with contents such as:

100.101.200.201 OK
100.101.200.202 OK
client1.mydomain.com OK

Run the commands "postmap /etc/postfix/access", and "postfix reload".

woo










hotchilli

Last edited by hotchilli; 5th July 2006 at 09:52.
Reply With Quote
  #4  
Old 5th July 2006, 11:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by hotchilli
mynetworks = 192.168.1.10/32, 127.0.0.1/8
I think this should do, and then you must tell your Windows machine to relay through your Postfix server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th July 2006, 00:06
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default postfix -relay

>falko wrote

>you must tell your Windows machine to relay through your Postfix server

I think i understand.

Do you mean for example telling the mail client on the Windows machine e.g. Outlook to send mail (using SMTP) via your mail server and collect it (using POP or IMAP) from your mail server. This can be done by putting the IP address of your mail server in the appropriate dialog boxes in Outlook.

hotchilli
Reply With Quote
  #6  
Old 6th July 2006, 13:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by hotchilli
Do you mean for example telling the mail client on the Windows machine e.g. Outlook to send mail (using SMTP) via your mail server and collect it (using POP or IMAP) from your mail server. This can be done by putting the IP address of your mail server in the appropriate dialog boxes in Outlook.
That's right.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th July 2006, 10:13
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default Ipv4

In the first post of this thread I asked about disableing IPV6.

you suggested :

?
Why do you want to disable it? It doesn't hurt to have it...


I thought that my problem may go away but after searching the internet
for an alternative soultion I find I must disable IPV6 why? see below
its to
do with inn2 a news server package.(InterNetNews)

-rw-r--r-- 1 news news 1312 2006-07-08 07:36 /var/log/news/news.crit
-----
Server running
Allowing remote connections
Parameters c 10 i 50 (0) l 1000000 o 1011 t 300 H 2 T 60 X 0 normal
specified
Not reserved
Readers follow enabled
Perl filtering enabled

ul 6 07:20:45 hotchilli innd: SERVER cant listen RCreader Address
already in use
Jul 7 07:35:47 hotchilli innd: SERVER cant listen RCreader Address
already in use
Jul 8 07:36:49 hotchilli innd: SERVER cant listen RCreader Address
already in use


If i disable IPV6 the problems go away but as you see from first the
post in this thread I get postfix warnings.i did suggest to place
inet_interfaces = IPV4 in main.cf but you asked to see:


postconf -d | grep inet_protocols

inet_interfaces = IPV4

AND

postconf -n | grep inet_protocols

inet_protocols = all

so is it ok to change the main.cf in postfix to inet_interfaces = IVP4?

hotchilli

Last edited by hotchilli; 8th July 2006 at 20:26.
Reply With Quote
  #8  
Old 9th July 2006, 13:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Quote:
Originally Posted by hotchilli
so is it ok to change the main.cf in postfix to inet_interfaces = IVP4?

hotchilli
Yes, that should work. Restart Postfix afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
IMAP question - Moving servers and mail. Brenton Installation/Configuration 11 14th May 2010 14:38
problems sending receiving mail on Postfix mavgh1 HOWTO-Related Questions 17 10th March 2006 12:43
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20
postfix problem flourishing General 1 7th December 2005 17:39


All times are GMT +2. The time now is 14:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.