Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd July 2006, 13:22
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default I broke it.. I think.. Email in is not being delivered?

Not sure what I did to brake (make it not work), but for some reason my email's [b]inp/b] are not being delivered, or disappearing!

The do get on the server, but that's it.. I can not find them anyware!

When I send an email to the server than this is in the "/var/log/mail.log" file.
(note that I have changed the domainname's and IP's shown)

Code:
Jul  3 12:58:04 host postfix/pickup[17053]: 271761250019: uid=0 from=<root>
Jul  3 12:58:04 host postfix/cleanup[25875]: 271761250019: message-id=<20060703105804.271761250019@mail.mydomain.tld>
Jul  3 12:58:04 host postfix/qmgr[17054]: 271761250019: from=<root@mail.mydomain.tld>, size=3463, nrcpt=1 (queue active)
Jul  3 12:58:04 host postfix/pickup[17053]: 2DADF125001A: uid=10009 from=<web1_root>
Jul  3 12:58:04 host postfix/cleanup[25875]: 2DADF125001A: message-id=<20060703105804.2DADF125001A@mail.mydomain.tld>
Jul  3 12:58:04 host postfix/qmgr[17054]: 2DADF125001A: from=<web1_root@mail.mydomain.tld>, size=373, nrcpt=1 (queue active)
Jul  3 12:58:04 host postfix/local[25892]: 2DADF125001A: to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/proc$
Jul  3 12:58:04 host postfix/qmgr[17054]: 2DADF125001A: removed
Jul  3 12:58:07 host postfix/local[24743]: 271761250019: to=<web1_root@mail.mydomain.tld>, orig_to=<root@mydomain.tld>, relay=local, delay=3, status=sen$
Jul  3 12:58:07 host postfix/qmgr[17054]: 271761250019: removed
Jul  3 12:58:09 host postfix/pickup[17053]: 2E6371250019: uid=0 from=<root>
Jul  3 12:58:09 host postfix/cleanup[25875]: 2E6371250019: message-id=<20060703105809.2E6371250019@mail.mydomain.tld>
Jul  3 12:58:09 host postfix/qmgr[17054]: 2E6371250019: from=<root@mail.mydomain.tld>, size=3463, nrcpt=1 (queue active)
Jul  3 12:58:09 host postfix/pickup[17053]: 34717125001A: uid=10009 from=<web1_root>
Jul  3 12:58:09 host postfix/cleanup[25875]: 34717125001A: message-id=<20060703105809.34717125001A@mail.mydomain.tld>
Jul  3 12:58:09 host postfix/qmgr[17054]: 34717125001A: from=<web1_root@mail.mydomain.tld>, size=373, nrcpt=1 (queue active)
Jul  3 12:58:09 host postfix/local[24743]: 34717125001A: to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/proc$
Jul  3 12:58:09 host postfix/qmgr[17054]: 34717125001A: removed
Jul  3 12:58:11 host postfix/smtpd[25949]: connect from aMY_IP.adsl.my_ISP.nl[MY_IP]
Jul  3 12:58:11 host postfix/smtpd[25949]: B0754125001A: client=aMY_IP.adsl.my_ISP.nl[MY_IP]
Jul  3 12:58:11 host postfix/cleanup[25875]: B0754125001A: message-id=<000501c69e8f$8fb2a7c0$0400000a@xeon2>
Jul  3 12:58:11 host postfix/qmgr[17054]: B0754125001A: from=<info@kijk.info>, size=1090, nrcpt=1 (queue active)
Jul  3 12:58:11 host postfix/smtpd[25949]: disconnect from aMY_IP.adsl.my_ISP.nl[MY_IP]
Jul  3 12:58:11 host postfix/pickup[17053]: C257D125001B: uid=10006 from=<web1_support>
Jul  3 12:58:11 host postfix/cleanup[25875]: C257D125001B: message-id=<20060703105811.C257D125001B@mail.mydomain.tld>
Jul  3 12:58:11 host postfix/qmgr[17054]: C257D125001B: from=<web1_support@mail.mydomain.tld>, size=385, nrcpt=1 (queue active)
Jul  3 12:58:11 host postfix/local[25966]: C257D125001B: to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/proc$
Jul  3 12:58:11 host postfix/qmgr[17054]: C257D125001B: removed
Jul  3 12:58:12 host postfix/local[25892]: 2E6371250019: to=<web1_root@mail.mydomain.tld>, orig_to=<root@mydomain.tld>, relay=local, delay=3, status=sen$
Jul  3 12:58:12 host postfix/qmgr[17054]: 2E6371250019: removed
As you can see, the server does receive the email.

I have added IPtables to my server, and I think it's sinds then that it does not work anymore! (maybe I should add some local stuff OK rule?)

My IPtables look like this (again I have changed the domainname's and IP's)

Code:
# Generated by iptables-save v1.2.11 on Fri Jun 30 14:52:16 2006
*mangle
:PREROUTING ACCEPT [10266818:5720867949]
:INPUT ACCEPT [10266803:5720867179]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [10100147:5385111770]
:POSTROUTING ACCEPT [10100155:5385112170]
COMMIT
# Completed on Fri Jun 30 14:52:16 2006
# Generated by iptables-save v1.2.11 on Fri Jun 30 14:52:16 2006
*nat
:PREROUTING ACCEPT [99928:5333447]
:POSTROUTING ACCEPT [209720:13139951]
:OUTPUT ACCEPT [209720:13139951]
COMMIT
# Completed on Fri Jun 30 14:52:16 2006
# Generated by iptables-save v1.2.11 on Fri Jun 30 14:52:16 2006
*filter
:PAROLE - [0:0]
:INPUT DROP [0:0]
:OUTPUT ACCEPT [0:0]
:PUB_IN - [0:0]
:INT_IN - [0:0]
:INT_OUT - [0:0]
:FORWARD DROP [0:0]
:PUB_OUT - [0:0]
-A INPUT -p tcp -m tcp -d 127.0.0.0/255.0.0.0 ! -i lo
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -s 224.0.0.0/240.0.0.0
-A INPUT -j LOG
-A INPUT -i eth+ -j PUB_IN
-A INPUT -j DROP
-A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT
-A FORWARD -j LOG
-A FORWARD -j DROP
-A OUTPUT -o eth+ -j PUB_OUT
-A INT_IN -p icmp -j ACCEPT
-A INT_IN -j DROP
-A INT_OUT -p icmp -j ACCEPT
-A INT_OUT -j ACCEPT
-A PAROLE -j ACCEPT
-A PUB_IN -p icmp -m icmp --icmp-type 3
-A PUB_IN -p icmp -m icmp --icmp-type 0
-A PUB_IN -p icmp -m icmp --icmp-type 11
-A PUB_IN -p icmp -m icmp --icmp-type 8
-A PUB_IN -p tcp -m tcp --dport 22
-A PUB_IN -p icmp -d MY_1st_IP -j ACCEPT
-A PUB_IN -p tcp -m tcp -d MY_1st_IP --dport 80 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_1st_IP --dport 81 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_1st_IP --dport 443 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_1st_IP --dport 8080 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_1st_IP --dport 10000 -j PAROLE
-A PUB_IN -p icmp -d MY_2nd_IP -j ACCEPT
-A PUB_IN -p tcp -m tcp -d MY_2nd_IP --dport 25 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_2nd_IP --dport 53 -j PAROLE
-A PUB_IN -p udp -m udp -d MY_2nd_IP --dport 53 -j PAROLE
-A PUB_IN -p icmp -d MY_3rd_IP -j ACCEPT
-A PUB_IN -p tcp -m tcp -d MY_3rd_IP --dport 53 -j PAROLE
-A PUB_OUT -j ACCEPT
-A PUB_IN -p udp -m udp -d MY_3rd_IP --dport 53 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_3rd_IP --dport 110 -j PAROLE
-A PUB_IN -p icmp -d MY_4th_IP
-A PUB_IN -p tcp -m tcp -d MY_4th_IP --dport 20:21 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_4th_IP --dport 900 -j PAROLE
-A PUB_IN -p tcp -m tcp -d MY_4th_IP --dport 30000:40000 -j PAROLE
-A PUB_IN -p udp -m udp --dport 53
-A PUB_IN -p icmp -j DROP
-A PUB_IN -j DROP
COMMIT
# Completed on Fri Jun 30 14:52:16 2006
It's even not working when I send a local email to a local users!

Sending emails to and outside email address does work fine!

Anyone here who can help me fix this problem
Reply With Quote
Sponsored Links
  #2  
Old 3rd July 2006, 14:22
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
 
Default

Nevermind.. For some reason I had enabled Maildir in ISPconfig..

After disabling it, all is working fine again :-)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why can't I get my email? woozyerdaddee General 7 1st July 2006 12:09
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43
UebiMiau locks out after server receives email sbecker Installation/Configuration 2 25th March 2006 00:00
Mails can't be delivered --::wizZzard::-- Installation/Configuration 32 25th January 2006 14:23
Recreate email Felipe General 3 13th December 2005 21:45


All times are GMT +2. The time now is 04:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.