Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 4th January 2013, 16:31
webguyz webguyz is offline
Senior Member
 
Join Date: Oct 2012
Location: Earth
Posts: 144
Thanks: 38
Thanked 18 Times in 15 Posts
Default

Quote:
Originally Posted by mylifenp View Post
You need to relay the mails you are sending using your ISPs smtp. Add these two lines in your main.cf in /etc/postfix

broken_sasl_auth_clients = yes
smtp_sasl_security_options =
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd <------
smtp_always_send_ehlo = yes
relayhost = smtp.yourisp.tld
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination


Then 'create /etc/postfix/sasl_passwd' and add these lines
smtp.yourisp.tld user@yourisp.tld:Password

If your ISPs SMTP server doesn't require authentification than you won't need to add 'smtp_sasl_password_maps .....' line and won't have to create 'sasl_passwd' file.

Hope this helps you.
The only problem is if you do this then your ISP will get totally ticked off at you when his IP's get blacklisted and then you really have a problem.

Is there any mechanism in ispConfig mail system that can activiated if its sees more then x emails per minute it then shoots an email to admin to warm them to take a closer look?
Reply With Quote
Sponsored Links
  #12  
Old 23rd September 2014, 13:29
recin recin is offline
Member
 
Join Date: Apr 2012
Posts: 43
Thanks: 4
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by erosbk View Post
Hello all,

Aside of hotmail, every mail sent by my mail server was arriving ok to inbox in gmail and yahoo. A client used our servers to send spam for two days... we kick it from our hosting, but right now, every mail send by my server is going directly to spam...

Do you know how can I give advise to yahoo and gmail about the situation, clarify that it has been fixed, and get all mails again to inbox?

If there is no solution to this, maybe I will have to use a different IP...
I have exactly the same problem.

Mails sended from my mail server were arriving OK to gmail inbox (even with no SPF nor DKIM records).

One account was sending spam for 2 days. We solved it but since then (1 month ago) our mails always arrive at gmail spam folder.
My senderscore was about 90, it go down to 50 and now is 75.
  • According to mxtoolbox im not on any blacklist
  • Reverse DNS are OK
  • SPF record OK (now, I didn't have it before)
  • DKIM record OK (now, I didn't have it before)
  • DMARC record OK (now, I didn't have it before)
  • I fill this form to gmail but i have no response
This is the header of a mail that goes to gmail spam (I changed mail accounts and IP for privacy reasons). It seems everything is OK:
Quote:
Delivered-To: account@gmail.com
Received: by 10.170.92.131 with SMTP id j125csp386538yka;
Tue, 23 Sep 2014 03:20:21 -0700 (PDT)
X-Received: by 10.180.104.7 with SMTP id ga7mr2190323wib.36.1411467620593;
Tue, 23 Sep 2014 03:20:20 -0700 (PDT)
Return-Path: <account@mydomain.es>
Received: from nicerterrae.c.ovd.interhost.com (nicerterrae.c.ovd.interhost.com. [1.2.3.4])
by mx.google.com with ESMTP id dy10si1746921wib.89.2014.09.23.03.20.19
for <account@gmail.com>;
Tue, 23 Sep 2014 03:20:20 -0700 (PDT)
Received-SPF: pass (google.com: domain of account@mydomain.es designates 1.2.3.4 as permitted sender) client-ip=1.2.3.4;
Authentication-Results: mx.google.com;
spf=pass (google.com: domain of account@mydomain.es designates 1.2.3.4 as permitted sender) smtp.mail=account@mydomain.es;
dkim=pass header.i=@mydomain.es;
dmarc=pass (p=NONE dis=NONE) header.from=mydomain.es
Received: from localhost (localhost [127.0.0.1])
by nicerterrae.c.ovd.interhost.com (Postfix) with ESMTP id 351B362452
for <account@gmail.com>; Tue, 23 Sep 2014 12:20:19 +0200 (CEST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=mydomain.es; h=
content-transfer-encoding:content-type:content-type:mime-version
:user-agent:from:from:subject:subject:date:date:message-id; s=
default; t=1411467618; x=1413282018; bh=kXPKBqt5rfzQUy21ux8y+Bf7
6AknnTLJH4iyXIjtd/0=; b=Wzr2IufsFk7bgBsqw++zbA1s9acD5VNdx+pihXwr
uWI+yCwjwrUvXdrZhewkukTgygvGKf2aVFtbcDFIkZapZk3y5o i0L4lUIx3e0RIx
ixosDGA2z/9Wxy8dF3mlJxeyKCsONzTG65RujlbjClc8gpC/ItM7qfEe0zoyWAxW
2M4=
X-Virus-Scanned: Debian amavisd-new at nicerterrae.c.ovd.interhost.com
Received: from nicerterrae.c.ovd.interhost.com ([127.0.0.1])
by localhost (nicerterrae.c.ovd.interhost.com [127.0.0.1]) (amavisd-new, port 10026)
with ESMTP id dh6wazpGxKYw for <account@gmail.com>;
Tue, 23 Sep 2014 12:20:18 +0200 (CEST)
Received: from mydomain.es (unknown [IPv6:::1])
by nicerterrae.c.ovd.interhost.com (Postfix) with ESMTP id 73B9E62450
for <account@gmail.com>; Tue, 23 Sep 2014 12:20:18 +0200 (CEST)
Received: from 93.156.201.130
(SquirrelMail authenticated user account@mydomain.es)
by mydomain.es with HTTP;
Tue, 23 Sep 2014 12:20:18 +0200
Message-ID: <afc02270a3c7a1356fa8d661299b3da8.squirrel@mydomai n.es>
Date: Tue, 23 Sep 2014 12:20:18 +0200
Subject: prueba desde webmail
From: account@mydomain.es
To: account@gmail.com
User-Agent: SquirrelMail/1.4.22
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
X-Priority: 3 (Normal)
Importance: Normal
Content-Transfer-Encoding: quoted-printable

prueba 2
What else can i do?
Reply With Quote
  #13  
Old 14th October 2014, 11:01
recin recin is offline
Member
 
Join Date: Apr 2012
Posts: 43
Thanks: 4
Thanked 6 Times in 6 Posts
Default

Finally gmail stop marking my mails as spam.
This happened exactly 1 month after the spam attack, when my senderscore goes from 80 to 99 (as it was before).

Here is a screenshot:


So in this case the only solution seems to be wait.

Meanwhile I tried postmark. They give you the option to send 25000 mails from they servers for free. You can configure your mail client (outlook, thunderbird...) to do that (there are other options but I didn't try them)

Last edited by recin; 14th October 2014 at 11:04.
Reply With Quote
  #14  
Old 14th October 2014, 11:03
recin recin is offline
Member
 
Join Date: Apr 2012
Posts: 43
Thanks: 4
Thanked 6 Times in 6 Posts
 
Default

Finally gmail stop marking my mails as spam.
This happened exactly 1 month after the spam attack, when my senderscore goes from 80 to 99 (as it was before).

Here is a screenshot:

So in this case the only solution seems to be wait.

Meanwhile I tried postmark. They give you the option to send 25000 mails from they servers for free. You can configure your mail client (outlook, thunderbird...) to do that (there are other options but I didn't try them)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 11:56
Sending email issue lezelf Installation/Configuration 15 9th August 2011 12:20
Can't receive mails baicunko Server Operation 12 3rd August 2011 23:02
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 15:49
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 18:02


All times are GMT +2. The time now is 19:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.