Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th July 2013, 23:30
fury fury is offline
Junior Member
 
Join Date: Jul 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Fresh install, cannot login admin/admin - error is "Username or Password empty"

I am setting up a server at home to prepare for colocating it and potentially harboring a few of my other sites and a friend's sites temporarily while he rebuilds his server. That in mind, I figured something like ISPConfig might help manage the different sites.

Ubuntu server 13.04 amd64
Fresh install of ISPConfig 3.x (from ISPConfig-3-stable.tar.gz)
nginx 1.2.6
MariaDB 10.0.3
PHP 5.5.0

Using the guide here: http://www.howtoforge.com/perfect-se...ot-ispconfig-3

I installed ISPConfig using the correct MySQL username and password (I can log in via mysql from the console with those credentials), and verified the password is md5('admin') in dbispconfig sys_user.

I get the login form, but the error returned to me when I try the default login admin/admin is Username or Password empty

It would appear that the HTML form for the login is not functioning properly - whatever javascript is supposed to translate form elements from dummy_* is not working, or perhaps dummy_login.html is not working. (dummy_login.html appears to be blank when I try to visit it or view source)

I have tried in Firefox version 22 million and Chrome version 28 gazillion. (I hate version numbers)

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 7th March 2014, 19:14
tanius tanius is offline
Junior Member
 
Join Date: Nov 2013
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Not for your case specifically, but for all others with this error message "Username or Password empty":

This can happen if ISPConfig cannot access its database at the moment. The simplest case for that to happen is (and was in my case) that the MySQL server is not running, or not responding. So try restarting it ("service mysql restart" on Ubuntu) and check if you can log in as MySQL root user ("mysql -u root -p" in Ubuntu).
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need be Validate - Extras for Perfect Server Debian / Ubuntu Users Wisdown Installation/Configuration 0 1st September 2012 02:07
Fail2ban configuration Captain Installation/Configuration 2 28th June 2011 20:48
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 12:24
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Fresh install can't login SamDenton Installation/Configuration 1 22nd March 2006 14:48


All times are GMT +2. The time now is 13:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.