Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > ISPConfig 3 Priority Support

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th October 2013, 10:43
misterm misterm is offline
Senior Member
 
Join Date: Aug 2005
Posts: 522
Thanks: 15
Thanked 7 Times in 6 Posts
Question postfix + SSL, the right to perform config

hello
I just found a tutorial on how to configure postfix on, how to add SSL certificate with Static IP.

http://www.sourcefields.com/2012/07/...-certificates/

When I add this configuration, it shows me this error if:

Quote:
IPfixe: port 25: Address already in use
Have you got this error is how you found the solution ...

thank you

Mz
__________________
ISPConfig, the panel fantastic , http://www.ispconfig.be/forums/
http://www.ispconfig.be/
Reply With Quote
Sponsored Links
  #2  
Old 8th October 2013, 10:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,983
Thanks: 825
Thanked 5,372 Times in 4,219 Posts
Default

a ssl certificate is alrady configured in postfix and dovecot when you followed one of the perfcet setup guides. It does not matter if you use a static Ip or not, the ssl configuration is the same.

If you want to use a officially signed ssl certificate, then you might want to use this guide:

http://www.howtoforge.com/securing-y...-from-startssl
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th October 2013, 11:15
misterm misterm is offline
Senior Member
 
Join Date: Aug 2005
Posts: 522
Thanks: 15
Thanked 7 Times in 6 Posts
Question

Hello Till
As you understand my question?
The link you provided to me, I already use.
What I'm looking for is simple, is the config, I find via the link I added in the previous message, but the worries, the error message tells me that in postfix port 25, 587, 465 is already in use, how to add this # is closed the other ports ... it does not work.

For here is the config I have done in the master.cf file

Quote:
#192.168.1.1:smtp inet n - - - - smtpd -o smtpd_sasl_auth_enable=yes -o smtpd_tls_key_file=/var/www/ssl.domain.tl/ssl/ssl.domain.tl.key -o smtpd_tls_cert_file=/var/www/ssl.domain.tl/ssl/ssl.domain.tl.crt
Mz
__________________
ISPConfig, the panel fantastic , http://www.ispconfig.be/forums/
http://www.ispconfig.be/
Reply With Quote
  #4  
Old 8th October 2013, 11:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,983
Thanks: 825
Thanked 5,372 Times in 4,219 Posts
Default

Quote:
The link you provided to me, I already use.
Ok, so you had already a correct and working ssl setup for static IP addresses. Why did you follow this other guide then?

By using the guide that you posted, you had bound postfix a second time to the same static ip address which resulted in a error. you can either use the guide that we provided to configure postfix or you use the other guide, but then you have to uncomment all port listeners in postfig main.cf (the smtp and mtps and submission line).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 8th October 2013, 13:53
misterm misterm is offline
Senior Member
 
Join Date: Aug 2005
Posts: 522
Thanks: 15
Thanked 7 Times in 6 Posts
 
Default

Ok till, but I am sure, you have the right configuration.
In the config you multiple IP under dovecot, I have not problem, but postfix, it's stuck ...
Thank you to you
Mz
__________________
ISPConfig, the panel fantastic , http://www.ispconfig.be/forums/
http://www.ispconfig.be/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
ftp authentication fails fooboo Installation/Configuration 34 26th March 2010 14:04
Spamsnake - Problem with spamassassin, FuzzyOcr and MySQL debuguser HOWTO-Related Questions 6 16th September 2008 18:37
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46


All times are GMT +2. The time now is 01:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.