Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd July 2013, 15:33
DarCow DarCow is offline
Junior Member
 
Join Date: Jul 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default MyDNS Not delegating new subdomains?

I am using ISPConfig 3.0.4.6 and have been for quite a while. At the beginning of the month my server was unexpectedly shutdown due to a power failure at my DC. When it came back up everything started as normal.

This weekend when I went to create several new subdomains, they did not appear to function. Previously the time between creating a new subdomain in the ISPConfig control panel and when it was accessible was between 5 and 10 minutes (often less than that). It has now been over 48 hours and the new subdomains still are not accessible.

What should I do to troubleshoot this problem? Domains and subdomains that were created prior to the unexpected shutdown continue to function as expected.

I am using Fedora.
Reply With Quote
Sponsored Links
  #2  
Old 25th July 2013, 19:27
DarCow DarCow is offline
Junior Member
 
Join Date: Jul 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does anyone have an idea on how to fix this?
Reply With Quote
  #3  
Old 25th July 2013, 19:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Try to restart mydns on the shell. you can also try to query the mydns server directly with:

dig @localhost sub.yourdomain.tld
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 25th July 2013, 20:52
DarCow DarCow is offline
Junior Member
 
Join Date: Jul 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have restarted it, yes.

This is the response I get when doing the test on the server (I substituted my-domain for the actual domain name)

Code:
dig @localhost mybb.my-domain.com

; <<>> DiG 9.8.4-RedHat-9.8.4-2.fc16 <<>> @localhost mybb.my-domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 7179
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;mybb.my-domain.com.          IN      A

;; AUTHORITY SECTION:
my-domain.com.        86400   IN      SOA     64.120.14.26. admin.my-domain.com. 2013040101 28800 7200 604800 86400

;; Query time: 2 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Jul 25 12:44:32 2013
;; MSG SIZE  rcvd: 95
Reply With Quote
  #5  
Old 25th July 2013, 21:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
 
Default

PLease check if the subdomains are added correctly in ispconfig, e.g. if you use a fqdn for the subdomain (like sub.domain.tld) then this has to end with a dot in dns. so instead of:

sub.domain.tld

you have to enter:

sub.domain.tld.

otherwise the zone name gets appended to the dns record and instead of sub.domain.tld you get sub.domain.tld.domain.tld
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
dns, fedora, mydns

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MyDNS notify problem sgabor Installation/Configuration 4 21st December 2011 19:01
MyDNS to PowerDNS : Safe Migration zenny Tips/Tricks/Mods 11 23rd December 2010 11:22
mydns failing daily csabo General 5 20th October 2010 20:54
MyDNS fails to start tristanlee85 Installation/Configuration 11 16th March 2010 16:49
ipsconfig3 on Lenny how-to troubles | myDNS tomdavidson Installation/Configuration 3 7th November 2009 20:33


All times are GMT +2. The time now is 18:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.