Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th July 2013, 22:39
olimortimer olimortimer is offline
Member
 
Join Date: Nov 2011
Posts: 30
Thanks: 6
Thanked 0 Times in 0 Posts
Default IE 301 Redirect Issue - WordPress

Hoping someone might be able to help...

I don't think this is a WordPress issue, hence posting here instead...

I run the latest ISPConfig version, and have an odd issue with a site I host.

In Chrome, the WordPress site (with Permalinks on) works correctly, however in IE it doesn't. It will load the homepage correctly, but any other pages take a while to load, then IE shows a generic "This page can't be displayed" error.

I started by removing all WordPress plugins, but the error didn't go away. Switching Permalinks off solves the issue. Switching Permalinks back on brings the issue back. I've even gone as far as scrapping the WordPress install, and starting again, in case any plugins had left some rubbish behind that was causing the problem. However, my "clean install" has this problem now.

If I look at the access logs after attempting to access a page with IE, all I see this;

Code:
x.xx.xx.xxx - - [15/Jul/2013:21:34:18 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:19 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
x.xx.xx.xxx - - [15/Jul/2013:21:34:20 +0100] "GET /category/blog HTTP/1.1" 301 20 "-" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
Accessing the site with Chrome works fine, and I see correct logs in the access.log file.

I have two other WordPress sites, both on top level domains, and they work correctly. This site I'm having the problems on, is on a subdomain. Could this be the issue?

Any help would be greatly appreciated, as this is extremely frustrating.
Reply With Quote
Sponsored Links
  #2  
Old 15th July 2013, 23:03
olimortimer olimortimer is offline
Member
 
Join Date: Nov 2011
Posts: 30
Thanks: 6
Thanked 0 Times in 0 Posts
 
Default

So instead of using a subdomain (setup as a website through ISPConfig), I tried with a manual subdomain - ie, a redirect into a directory. The site loaded fine for a couple of pages, and then suddenly stopped working, and 301 errors were thrown up.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aliasdomain 301 Redirect Not Working Eleven Cool Installation/Configuration 0 22nd September 2012 23:31
redirect loop issue lezelf Server Operation 4 13th October 2011 09:16
Alias domain 301 redirect tio289 Tips/Tricks/Mods 2 16th July 2010 07:25
Totally Frustrated with WordPress issue -- PLEASE HELP! jkrell HOWTO-Related Questions 0 28th December 2009 18:48
Apache 301 redirect - file names with spaces hairydog2 General 2 8th January 2007 00:29


All times are GMT +2. The time now is 20:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.