#1  
Old 10th July 2013, 14:58
smartin smartin is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 3
Thanked 0 Times in 0 Posts
Default Newb: Can't get WebDav working

Hi,

I'm hoping this is something simple...

I'm using ISPC 3.0.5.2
Ubuntu server 8.06 LTS (?)

Apache modules dav and dav_fs are enabled

My domain is xcvb.com (example)

I set up a webdav user called nwilldav, which actually becomes xcvbnwilldav.
I set the path to nwill

When I use the OSX finder (10.6.8) I: Go > Connect to server
Server address: http://www.xcvb.com/webdav/nwill

I get the error:
<Connection Failed
There was an error connecting to the server www.xcvb.com. Check the server name or IP address and try again>

The site itself is working fine so it's not a DNS issue.

If I use a WebDav client (Transmit) with the following settings entered:
Server: www.xcvb.com
Username: xcvbnwilldav
Password:
Initial path: <Blank>
Port: 80
Protocol: WebDAV

I get: Cannot connect to www.xcvb.com

If I set the "Initial path" to webdav/nwill
I get a 403 error.

What am I doing wrong?

Hope someone can help :-)

Thanks!

S
Reply With Quote
Sponsored Links
  #2  
Old 10th July 2013, 17:42
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 197
Thanks: 25
Thanked 60 Times in 44 Posts
Default

Check the website's/global apache error log to see if it contains useful information.

Depending on your mod_security rules (if used) this may block it. There are already 2/3 rules whitelisted...but you may need to add more.

tail -f /var/www/<website.tld>/log/error.log while trying and see what shows up.
__________________
Rackster Internet Services's presences:
Official | Open Source | Github | Facebook | Twitter
Reply With Quote
  #3  
Old 10th July 2013, 18:35
smartin smartin is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by MaddinXx View Post
Check the website's/global apache error log to see if it contains useful information.

Depending on your mod_security rules (if used) this may block it. There are already 2/3 rules whitelisted...but you may need to add more.

tail -f /var/www/<website.tld>/log/error.log while trying and see what shows up.
MaddinXx,

Thanks for your time...

Not 100% sure I'm looking in the right places but...
Site error log:
[Wed Jul 10 13:46:15 2013] [error] [client 192.168.0.6] (13)Permission denied: access to /webdav/nwill denied
[Wed Jul 10 13:47:10 2013] [error] [client 192.168.0.6] (13)Permission denied: access to /webdav/nwill denied
[Wed Jul 10 13:51:23 2013] [error] [client 192.168.0.6] (13)Permission denied: access to /webdav/nwill/ denied
[Wed Jul 10 15:55:02 2013] [error] [client xxx] (13)Permission denied: access to /webdav/nwill denied
[Wed Jul 10 15:55:46 2013] [error] [client xxx] (13)Permission denied: access to /webdav/nwill denied
[Wed Jul 10 16:52:44 2013] [error] [client 192.168.0.6] (13)Permission denied: access to /webdav/nwill denied
[Wed Jul 10 16:52:53 2013] [error] [client 192.168.0.6] (13)Permission denied: access to /webdav/nwill denied

Main apache error log:
[Wed Jul 10 13:03:11 2013] [notice] mod_fcgid: call /var/www/ispconfig/sites/webdav_user_edit.php with wrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
[Wed Jul 10 13:10:33 2013] [notice] mod_fcgid: call /var/www/ispconfig/nav.php with wrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter

Main access log:
127.0.0.1 - - [10/Jul/2013:16:25:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:16:30:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:16:35:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:16:40:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:16:45:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
210.42.88.221 - - [10/Jul/2013:16:49:16 +0100] "HEAD / HTTP/1.0" 200 - "-" "-"
127.0.0.1 - - [10/Jul/2013:16:50:02 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:16:55:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:17:00:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:17:05:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:17:10:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:17:15:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:17:20:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [10/Jul/2013:17:25:01 +0100] "GET / HTTP/1.1" 200 45 "-" "Mozilla/5.0 (ISPConfig monitor)"

The tail command didn't show me any live information...

Any help?

S
Reply With Quote
  #4  
Old 10th July 2013, 18:55
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 197
Thanks: 25
Thanked 60 Times in 44 Posts
Default

Have you activated auth_digest apache module?

a2enmod auth_digest && service apache2 restart

Otherwise I don't know what could be wrong and you'll have to wait for someone else to help you.

Please double check your credentials as well (as there doesn't seem to be no error - and simply login fails).

Also, check that the apache vhost for this domain includes a part for WebDAV:

<IfModule mod_dav_fs.c>
// here's more...
</IfModule>
__________________
Rackster Internet Services's presences:
Official | Open Source | Github | Facebook | Twitter
Reply With Quote
  #5  
Old 11th July 2013, 09:53
smartin smartin is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by MaddinXx View Post
Have you activated auth_digest apache module?

a2enmod auth_digest && service apache2 restart

Otherwise I don't know what could be wrong and you'll have to wait for someone else to help you.

Please double check your credentials as well (as there doesn't seem to be no error - and simply login fails).

Also, check that the apache vhost for this domain includes a part for WebDAV:

<IfModule mod_dav_fs.c>
// here's more...
</IfModule>
MaddinXx,

auth_digest was enabled...

When I look at /etc/apache2/sites-enabled/xcvb.com.vhost, there's nothing in there at all. Am I looking in the right place? Is there a global vhost...?

Thanks again :-)

S
Reply With Quote
  #6  
Old 11th July 2013, 23:02
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 197
Thanks: 25
Thanked 60 Times in 44 Posts
Default

Quote:
Originally Posted by smartin View Post
When I look at /etc/apache2/sites-enabled/xcvb.com.vhost, there's nothing in there at all. Am I looking in the right place? Is there a global vhost...?
But the website works? You meant no WebDav section or no content at all?

Please update the website's setting (e.g. switch SSI on and off) to see if it recreates that file. Make sure to tail -f /var/log/ispconfig/cron.log in the meanwhile to check for errors that might encounter...as ISPConfig seems to have problems on your server creating the vhost files.
__________________
Rackster Internet Services's presences:
Official | Open Source | Github | Facebook | Twitter
Reply With Quote
  #7  
Old 12th July 2013, 11:07
smartin smartin is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by MaddinXx View Post
But the website works? You meant no WebDav section or no content at all?

Please update the website's setting (e.g. switch SSI on and off) to see if it recreates that file. Make sure to tail -f /var/log/ispconfig/cron.log in the meanwhile to check for errors that might encounter...as ISPConfig seems to have problems on your server creating the vhost files.
MaddiXx,

The vhosts file had no content whatever.

The site does work but it's just a static html site so may be very forgiving...?

This is what I got from your command as I switched SSI on and off:
[Fri Jul 12 10:00:12 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
[Fri Jul 12 10:00:22 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
PHP Warning: symlink(): File exists in /usr/local/ispconfig/server/plugins-available/webmail_symlink_plugin.inc.php on line 114
[Fri Jul 12 10:00:25 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
[Fri Jul 12 10:00:35 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
PHP Warning: symlink(): File exists in /usr/local/ispconfig/server/plugins-available/webmail_symlink_plugin.inc.php on line 114

Still nothing in the vhosts file...

Make any sense...? :-)

S
Reply With Quote
Reply

Bookmarks

Tags
webdav

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig not writing vhost changes to disk 99miles General 22 5th July 2012 09:31
ISPConfig 3.0.3.2 & Webdav & 403 Forbidden Rescue9 Installation/Configuration 6 4th December 2011 16:05
my site not working busykid Installation/Configuration 1 27th September 2011 10:55
Newb: Is this WebDav setup going to work? smartin Installation/Configuration 34 4th March 2010 18:15
Newb: Please advise me on good working practices Slowhand Server Operation 2 25th June 2009 22:55


All times are GMT +2. The time now is 09:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.