Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th July 2013, 11:52
seopower seopower is offline
Junior Member
 
Join Date: Jul 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Adding a Site - Problem with website_domain

Hello,

I have installed ISPConfig 3.0.3 and looking for a way to create sites without having Symlinks.

My directory structure should look like:

/var/www/domainname1.com/web
/var/www/domainname2.com/web

But when I use /var/www/[website_domain] in Website path field under Server settings it create a directory names [website_domain].

Is it possible to create sites simply having one directory with domain name and without symlinks or client id folders?
Reply With Quote
Sponsored Links
  #2  
Old 11th July 2013, 11:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,676
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
Default

Quote:
Is it possible to create sites simply having one directory with domain name and without symlinks or client id folders?
No, thats not possible as your whole servers etup would break as soon as you change a website domainnname. For that reason, ispconfig uses folders based on client and web ID's and symlinks for easier shell navigation.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th July 2013, 13:17
seopower seopower is offline
Junior Member
 
Join Date: Jul 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually I need to point multiple websites to a single directory (a CMS hosting multiple sites) ... How can I do that ?
Reply With Quote
  #4  
Old 11th July 2013, 13:56
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 922
Thanks: 16
Thanked 259 Times in 206 Posts
 
Default

I think you should simply use alias domains without setting any redirect type then.
__________________
Marius Cramer

pixcept KG
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem when adding more than one site gibbo1715 Installation/Configuration 21 31st March 2012 05:31
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
problem recreating deleted site jusdisgi Installation/Configuration 5 4th June 2008 19:34
Web Site Problem TinkerAllison Installation/Configuration 3 1st April 2007 19:25
Problem with user adding K_meleonu Installation/Configuration 3 18th May 2006 09:39


All times are GMT +2. The time now is 21:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.