Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th July 2013, 00:12
smanettone smanettone is offline
Junior Member
 
Join Date: Jul 2013
Location: Naples
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Question problem mail server in virtual multiserver configuration

sorry for my English...

i have completed this tutorial virtual multiserver:
http://www.howtoforge.com/virtual-mu...th-ispconfig-3

(but i use proxmox)

SITUATION

Physical Server
ip address: public address
Webserver
ip address:192.168.0.1
Mail Server
ip address:192.168.0.2
Ns1
ip address:192.168.0.3
Ns2
ip address:192.168.0.4

i have configure nat forwarding in physical server
port 80, 8080, 21 in web server
port 110, 25 in mail server
port 53 in ns server

all work great but the mail server not send mail
what's the problem?!?!

thankyou for reply
Reply With Quote
Sponsored Links
  #2  
Old 10th July 2013, 17:47
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 200
Thanks: 26
Thanked 64 Times in 47 Posts
Default

Try opening these ports on mail server:

25,110,143,465,585,587,993,995

You may want to check which port is for what (and if you really need it) - but I guess you should at least open port 587 too.

Are there any errors in /var/log/mail.err or /var/log/mail.log?
Reply With Quote
The Following User Says Thank You to MaddinXx For This Useful Post:
smanettone (10th July 2013)
  #3  
Old 10th July 2013, 18:57
smanettone smanettone is offline
Junior Member
 
Join Date: Jul 2013
Location: Naples
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Tnx MaddinXx, i have try your instructions but the mail server no work
when i configure the mail-client (outlook, thundebird, ecc...), pop test ok bust smtp test fail.

i have install roundcube on web server and the login work correctly
i can send (i use php send) but i don't receive

i can post log or configuration file if you want

pls help me!!!
Reply With Quote
  #4  
Old 10th July 2013, 19:04
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 200
Thanks: 26
Thanked 64 Times in 47 Posts
Default

Can you post output of

netstat --listening | grep smtp

and

netstat --listening | grep submission

to check if Postfix is running and

cat /var/log/mail.log | grep err

as well to see if there are any errors in the log?
Reply With Quote
The Following User Says Thank You to MaddinXx For This Useful Post:
smanettone (10th July 2013)
  #5  
Old 10th July 2013, 19:13
smanettone smanettone is offline
Junior Member
 
Join Date: Jul 2013
Location: Naples
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default

this is output of netstat --listening | grep smtp:

root@mail:~# netstat --listening | grep smtp
tcp 0 0 127.0.0.2:ssmtp *:* LISTEN
tcp 0 0 localhost.localdo:ssmtp *:* LISTEN
tcp 0 0 127.0.0.2:smtp *:* LISTEN
tcp 0 0 localhost.localdom:smtp *:* LISTEN
tcp6 0 0 localhost:ssmtp [::]:* LISTEN
tcp6 0 0 localhost:smtp [::]:* LISTEN
unix 2 [ ACC ] STREAM LISTENING 1246918 private/smtp
unix 2 [ ACC ] STREAM LISTENING 1246974 private/bsmtp



this is output netstat --listening | grep submission

root@mail:~# netstat --listening | grep submission
tcp 0 0 127.0.0.2:submission *:* LISTEN
tcp 0 0 localhost.lo:submission *:* LISTEN
tcp6 0 0 localhost:submission [::]:* LISTEN

output of cat /var/log/mail.log | grep err:

Jul 6 17:32:40 mail spamd[1212]: logger: removing stderr method
Jul 6 17:55:11 mail spamd[1193]: logger: removing stderr method
Jul 6 18:42:44 mail spamd[1217]: logger: removing stderr method
Jul 7 07:17:05 mail spamd[1219]: logger: removing stderr method
Jul 7 07:30:41 mail spamd[1221]: logger: removing stderr method
Jul 7 07:48:48 mail spamd[487]: logger: removing stderr method
Jul 7 07:52:47 mail spamd[746]: logger: removing stderr method
Jul 7 07:58:00 mail spamd[739]: logger: removing stderr method
Jul 8 18:16:17 mail spamd[740]: logger: removing stderr method
Jul 9 22:13:32 mail spamd[751]: logger: removing stderr method

Tnx for Reply

Last edited by smanettone; 10th July 2013 at 19:17.
Reply With Quote
  #6  
Old 10th July 2013, 19:33
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 200
Thanks: 26
Thanked 64 Times in 47 Posts
Default

Doesn't this tcp 0 0 127.0.0.2:ssmtp *:* LISTEN mean it's listening on localhost (or 127.0.0.2) only?

In /etc/postfix/main.cf have you:

Code:
[...]
myorigin = /etc/mailname
[...]
myhostname = <your FQDN>
[...]
myorigin = /etc/mailname
[...]
mydestination = <your FQDN>, localhost, localhost.localdomain
[...]
Postfix needs to be restarted afterwards. Not sure if this is correct, but I highly guess there's somewhere a problem with where Postfix is listening...
Reply With Quote
  #7  
Old 10th July 2013, 19:45
smanettone smanettone is offline
Junior Member
 
Join Date: Jul 2013
Location: Naples
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default

In /etc/postfix/main.cf
i have only

myhostname = mail.xxxxxx.it
and
mydestination = /etc/postfix/local-host-names

i haven't myorigin = /etc/mailname
Reply With Quote
  #8  
Old 15th July 2013, 12:28
smanettone smanettone is offline
Junior Member
 
Join Date: Jul 2013
Location: Naples
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

i have problem with server mail...
another solution???
Reply With Quote
Reply

Bookmarks

Tags
mail send/receive, postfix, smtp, virtual server

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
installing squirrelmail on Debian with ispconfig3 saco721 Installation/Configuration 18 1st April 2011 17:57
mail authentication failure - unknown user or password evok Installation/Configuration 9 16th October 2010 06:37
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08


All times are GMT +2. The time now is 22:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.