Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 3rd July 2013, 11:08
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default problem implementing wildcard SSL

i am having problem getting wildcard SSL to work in ispconfig.

I have followed some guide in this forum on implementing pre-configured SSL but it still doesn't work.

Getting error
Code:
Secure Connection Failed

          An error occurred during a connection to domain.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)
I even tried to manually configure the SSL but it doesn't work.

I am using ubuntu 10.04LTS.

I have ispconfig gui running in self-created SSL cert. Could this be the reason for the problem? Perhaps I should disable SSL in ispconfig gui and then try to configure the website again to use SSL?

Would really appreciate help from the pros here.

more errors from apache logs:
Quote:
[Wed Jul 03 15:58:03 2013] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
Quote:
[Wed Jul 03 15:58:03 2013] [warn] RSA server certificate wildcard CommonName (CN) `*.domain.com' does NOT match server name!?
thanks.

Last edited by abubin; 3rd July 2013 at 11:11.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mails: fine > recive: bad Moundy General 1 19th June 2012 23:40
Problem With API Remote User Connections on SSL CubAfull Installation/Configuration 2 13th June 2012 14:21
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
problem with ssl cappeonghe General 1 7th August 2006 13:22


All times are GMT +2. The time now is 06:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.