Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th June 2013, 20:25
EllisP EllisP is offline
Junior Member
 
Join Date: Jun 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with sending emails outside of own domain.

Greetings;


Whenever I try to send emails from my local domain to my gmail; I get an error
Code:
Jun 19 20:13:56 ubuntuserver postfix/smtpd[3150]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 451 4.3.0 <*********@gmail.com>: Temporary lookup failure; from=<admin@example.com> to=<*********@gmail.com> proto=ESMTP helo=<[192.168.21.120]>
How come I'm getting this error? 451 4.3.0 Temporary lookup failure.
Tried googling already and it didn't really help.

I set up my Ubuntu-server using The Perfect Server - Ubuntu 12.10 (Apache2, BIND, Dovecot, ISPConfig 3) Howto
Sending emails within my own domain is no problem!

Kind regards;

Ellis
Reply With Quote
Sponsored Links
  #2  
Old 21st June 2013, 10:19
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

what's the output of
Code:
 postconf -n | egrep -i -e "mynetworks|relay_domains"
Reply With Quote
  #3  
Old 21st June 2013, 16:32
mzandstra mzandstra is offline
Junior Member
 
Join Date: Mar 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS settings?

Also the contents of your /etc/resolv.conf would be helpful. Can you ping outside domains from the server CLI?
Reply With Quote
  #4  
Old 24th June 2013, 19:10
EllisP EllisP is offline
Junior Member
 
Join Date: Jun 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Already found the problem; sorry for making an unnecessary thread!
Reply With Quote
  #5  
Old 24th June 2013, 21:34
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

i hate when people say they found the problem but don't say what was it
Reply With Quote
  #6  
Old 25th June 2013, 16:20
mzandstra mzandstra is offline
Junior Member
 
Join Date: Mar 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Yeah it's pretty annoying for future Googlers with the same issue haha...

Without knowing any details, my suggestion would be to check resolv.conf and dig the DNS server for the relevant records.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Major recovery Toucan Installation/Configuration 18 9th August 2011 11:45
Postfix not forwarding for some domains flappy Installation/Configuration 3 21st November 2010 17:57
Stange mail problem The-Ghost Installation/Configuration 6 25th April 2010 19:59
Fedora 12 - Strage problem - Freezes K_meleonu Installation/Configuration 6 3rd March 2010 18:42
Sending emails with PHP Izinyoka General 8 9th April 2009 15:52


All times are GMT +2. The time now is 22:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.