Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th May 2013, 17:42
mhpcomputerservices mhpcomputerservices is offline
HowtoForge Supporter
 
Join Date: Dec 2006
Location: Walsall, England
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Send a message via MSN to mhpcomputerservices Send a message via Skype™ to mhpcomputerservices
Default Wordpress 3.5.1 "client intended to send too large body"

I've migrated a Wordpress 5.3.1 site ....

-from-

Debian 6.0
Ispconfig 3.0.5.2
Apache 2.2.16
php 5.3.24 (fast-cgi)

-to-

Ubuntu 12.0.4.2LTS
Ispconfig 3.0.5.2
Nginx 1.4.1
php 5.3.10 (php-fpm)

All was working fine on the original server. However, on the new server when attempting to upload an image we see a wordpress 'HTTP error'.

Examining the Nginx logs shows:-
Code:
2013/05/20 17:04:25 [error] 5219#0: *84543 client intended to send too large body: 1438769 bytes, client: *EDITED*, server: *EDITED*.co.uk, request: "POST /wp-admin/async-upload.php HTTP/1.1", host: "www.*EDITED*.co.uk", referrer: "http://www.*EDITED*.co.uk/wp-admin/media-new.php"
This is driving me nuts! I've changed client_max_body_size to 200M and it has no effect

Code:
root@i7:/etc/nginx# grep -R 'client_max_body_size' *
nginx.conf:        client_max_body_size 200M;
sites-available/apps.vhost:        client_max_body_size 200M;
sites-available/ispconfig.vhost:        client_max_body_size 200M;
sites-enabled/000-ispconfig.vhost:        client_max_body_size 200M;
sites-enabled/000-apps.vhost:        client_max_body_size 200M;
php.ini has also been altered to suit:
Code:
upload_max_filesize = 200M
Code:
post_max_size = 200M
Ispconfig Nginx Directives
Code:
 location = /favicon.ico {
                log_not_found off;
                access_log off;
        }
 
        location = /robots.txt {
                allow all;
                log_not_found off;
                access_log off;
        }
 
        location / {
                # This is cool because no php is touched for static content. 
                # include the "?$args" part so non-default permalinks doesn't break when using query string
                try_files $uri $uri/ /index.php?$args;
        }
 
        location ~ \.php$ {
                #NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
                include fastcgi.conf;
                fastcgi_intercept_errors on;
                fastcgi_pass php;
        }
 
        location ~* \.(js|css|png|jpg|jpeg|gif|ico)$ {
                expires max;
                log_not_found off;
        }
Ispconfig Custom php.ini settings
Code:
cgi.fix_pathinfo = 0;
Can anyone offer any advise here?

Thanks
__________________
Regards
Marcus

*Computer Cables
*Running on Multiserver Setup (5 Servers) Debian 6.0 & ISPConfig 3.0.5.2
Reply With Quote
Sponsored Links
  #2  
Old 21st May 2013, 10:36
mhpcomputerservices mhpcomputerservices is offline
HowtoForge Supporter
 
Join Date: Dec 2006
Location: Walsall, England
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Send a message via MSN to mhpcomputerservices Send a message via Skype™ to mhpcomputerservices
Default

Anyone?
__________________
Regards
Marcus

*Computer Cables
*Running on Multiserver Setup (5 Servers) Debian 6.0 & ISPConfig 3.0.5.2
Reply With Quote
  #3  
Old 23rd June 2013, 05:22
jaypabs jaypabs is offline
Member
 
Join Date: Jun 2013
Posts: 68
Thanks: 0
Thanked 1 Time in 1 Post
Default

I'm having the same problem also. Did you fix yours?

I'm also using php5-fpm, nginx.
Reply With Quote
  #4  
Old 24th June 2013, 16:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Can you add

Code:
client_max_body_size to 200M;
to the nginx Directives field?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
nginx, upload, wordpress

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My postfix server is beeing used to send large ammounts of spam. bob808 Server Operation 2 27th April 2009 12:37


All times are GMT +2. The time now is 02:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.