Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 21st June 2013, 22:08
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default awstats - Error: SiteDomain parameter not defined in your config/domain file

Hello,

I installed most of my software before installing ISPConfig; this is usually the preferred order-of-operations, as I understand it, which makes sense in that it allows ISPC to determine what is installed and configure itself accordingly. Among the packages I installed was awstats.

The problem I'm having is that every 10 minutes I receive an email that results from a cron job that does:

Code:
[ -x /usr/share/awstats/tools/update.sh ] && /usr/share/awstats/tools/update.sh
The resultant error is:

Code:
Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.
Setup ('/etc/awstats/awstats.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).
Do I simply need to disable this cron job, e.g., because ISPC calls its own job to compile stats?

Or is some other measure required? I don't remember having to perform any configuration of awstats on servers that I've built in the past with ISPC.

I have ISPC 3.0.5.2 and haven't modified any of the default values relating to Web-stats in the GUI.

Thanks for any help!
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tried to compile a kernel but: bryzf Kernel Questions 0 19th January 2013 23:48
scriptdir and bindir in RKHUNTER stigge2000 Server Operation 6 21st December 2012 13:57
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Cannot send or receive mail farbrorc Installation/Configuration 6 24th January 2010 11:56
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57


All times are GMT +2. The time now is 06:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.