Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 21st June 2013, 11:19
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Exclamation

Bump! Bump!! Bump!!! [3 bumps because the forum does not allow less than 10 chars ;-)]
Reply With Quote
Sponsored Links
  #12  
Old 21st June 2013, 11:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
This is a completely new installation and only with two domains created to check whether SNI works by default.
SNI is compiled into the webserver, it does not require any additional configuration so it works by default.

Quote:
Else, can someone share their experience setting up multiple ssl sites with a single public ip, using SNI feature of apache2 and nginx in ISPConfig 3.0.5.2? Appreciate it! Thanks!
Works fine here on all servers. Just perfect server setup with no additional configuration.

Quote:
1) http://<domain.tld> got "403 Forbidden" message showing in error.log:
You enabled the default ssl vhost which will cause the webserver to redirect requests to a directory that should not be accessed and the correct reply is a forbiden error. The default-ssl vhost should not be enabled if you want to use sni for websites in ispconfig, thats why the perfect setup does not instruct you to enable it.

If you wnat to use ssl in a website and get the website when you enter https in fron of the domain, then you have to enable ssl for that website in ispconfig and create a ssl cert for it in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
zenny (21st June 2013)
  #13  
Old 21st June 2013, 18:40
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Arrow

Quote:
Originally Posted by till View Post
SNI is compiled into the webserver, it does not require any additional configuration so it works by default.



Works fine here on all servers. Just perfect server setup with no additional configuration.
Only varnish is setup in front of apache listening to port 80 which I guess have nothing to do with the port 443 to which apache listens to for ssl.



Quote:
You enabled the default ssl vhost which will cause the webserver to redirect requests to a directory that should not be accessed and the correct reply is a forbiden error. The default-ssl vhost should not be enabled if you want to use sni for websites in ispconfig, thats why the perfect setup does not instruct you to enable it.
I discovered that and disabled the default-ssl, but in that case the server is back to square one as OP.

Quote:
If you wnat to use ssl in a website and get the website when you enter https in fron of the domain, then you have to enable ssl for that website in ispconfig and create a ssl cert for it in ispconfig.
Done exactly, but no go. And here I am to seek your help. On normal apache2 setup, it works fine, but not with ISPconfig3, that is where I am stuck.

Have a nice Midsummer!
Reply With Quote
  #14  
Old 25th June 2013, 02:08
JohnyGoerend JohnyGoerend is offline
Junior Member
 
Join Date: Jun 2013
Location: Luxembourg
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I hope I won't insult you with this proposition, but I had the same error this evening and found this thread while googling it, only that I found the "solution" on my side: I configured the certificates and IP addresses all correctly, I just forgot to enable SSL in the site's settings (in the "Domain" tab)! Nothing less.

It's a bit confusing that it has to be enabled seperately from the SSL tab, but also makes sense somehow
Reply With Quote
  #15  
Old 25th June 2013, 09:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
It's a bit confusing that it has to be enabled seperately from the SSL tab, but also makes sense somehow
The reason for separating the settings is that ispconfig is made for hosting companys. There you have administrators and client. The ssl checkbox exists so that a administrator can enable / disable the ability for the client to have a ssl cert and all these website limits are on the first tab. So when its active, the client can create and manage its ssl cert on the ssl tab.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 25th June 2013, 10:16
JohnyGoerend JohnyGoerend is offline
Junior Member
 
Join Date: Jun 2013
Location: Luxembourg
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I understand and I know, that's why I said that it also makes sense Only if you're new to ispconfig and want to setup SSL, you might easily forget this option
Reply With Quote
  #17  
Old 26th June 2013, 13:53
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
 
Unhappy

In my case, I enabled SSL to all domains and created SSL certificates to each of them using the webgui, yet no go.
Reply With Quote
Reply

Bookmarks

Tags
https ispconfig broke, ispconfi3, multiple ssl on one ip, sni

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to get my DNS to work using ISPConfig petersfreeman Server Operation 2 22nd June 2012 08:23
ISPConfig 3 / Apache Crash / SNI Pasco Installation/Configuration 7 16th December 2011 10:08
ISPConfig 3 Postfix Problem (Tutorial Perfect Server Centos) topmaverick Server Operation 3 19th May 2011 10:59
Terrible server speeds gAnDo HOWTO-Related Questions 3 14th February 2008 18:31


All times are GMT +2. The time now is 07:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.