Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 21st June 2013, 09:09
mrtnzlml mrtnzlml is offline
Junior Member
 
Join Date: Feb 2013
Location: Czech Republic
Posts: 12
Thanks: 1
Thanked 3 Times in 3 Posts
Default SOAP Error: looks like we got no XML document

Hi! I have problem with client_update remote API function. It returns SOAP Error: looks like we got no XML document...
Code:
if($session_id = $client->login($username,$password)) {
	echo 'Logged successfull. Session ID:'.$session_id.'<br />';    //OK
}
$client_record = $client->client_get($session_id, $client_id);    //OK
$vals['contact_name'] = 'brush';
$new_record = array_merge($client_record, $vals);    //OK, contact_name changed
$affected_rows = $client->client_update($session_id, $client_id, $reseller_id, $new_record);    //FAIL
In catch $client->__getLastResponse() contains incomplete response:
Code:
... `usertheme` = 'default', `street` = '', `zip` = '', `city` = '', `state` = '', `country` = 'CZ', `telephone` = '', `mobile` = '', `fax` = '', `em
(last em - probably email is incomplete) and SoapFault -> getMessage returns looks like we got no XML document.

Any idea where is the problem?
Reply With Quote
The Following User Says Thank You to mrtnzlml For This Useful Post:
alexeyttsy3922 (23rd June 2013)
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable SOAP help trcinc1 Installation/Configuration 0 3rd July 2008 19:01
Remoting - Invalid XML Returned evilfish Installation/Configuration 2 21st November 2007 12:50
Strange Soap Class error using Remoting with ISPConfig 2.2.16 - Junk after XML??? bpmee General 1 13th September 2007 04:53
Cannot create client, reseller and hosting plan crapufish Installation/Configuration 22 15th March 2007 10:27
Document for setup Apache2 with SSL/TLS satimis Server Operation 2 25th November 2006 14:50


All times are GMT +2. The time now is 03:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.