Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > ISPConfig 3 Priority Support

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th June 2013, 06:18
sipherdee sipherdee is offline
HowtoForge Supporter
 
Join Date: Jun 2013
Location: Montreal, QC, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to sipherdee Send a message via Skype™ to sipherdee
Default Unable to generate a CSR using the control panel (continued)

Hi! Last week, I started this thread:

http://www.howtoforge.com/forums/showthread.php?t=62178

I am still looking for a solution. What I am trying to do is to use ISPConfig to generate a CSR and nothing is happening when I select 'Create Certificate'.

State = QC
Locality = Montreal
Organisation = Organisation Name
Organisation Unit = Name
Country = Canada
SSL Domain = host.domain.ca

As you can see, no special characters are being used. Do you know which log files that could help me troubleshoot this issue?

I would appreciate if you have any ideas and I will post what I find here. Thanks in advance!
Reply With Quote
Sponsored Links
  #2  
Old 19th June 2013, 10:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

Please see here for debug instructions for the server process:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 19th June 2013, 17:33
sipherdee sipherdee is offline
HowtoForge Supporter
 
Join Date: Jun 2013
Location: Montreal, QC, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to sipherdee Send a message via Skype™ to sipherdee
Thumbs up

Thanks Till, this is exactly what I needed!

PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 186
PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 187
PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 188
PHP Warning: exec() has been disabled for security reasons in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 197

I removed 'disable_functions = exec' from our 'php.ini' file and I was able to create a self-signed certificate.
Reply With Quote
  #4  
Old 20th June 2013, 11:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
 
Default

You can place a copy of your php.ini in this path:

/usr/local/ispconfig/server/lib/php.ini

If this file exists, it will be used instaed of the global php.ini for the ISPConfig server process.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to generate a CSR using the control panel sipherdee Installation/Configuration 3 12th June 2013 18:00
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 02:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.