Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th June 2013, 12:30
davefrooney davefrooney is offline
Junior Member
 
Join Date: Apr 2011
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Listen on Multiple IP's in HAProxy?

I have 3 IP's pointing at my load balancer. I currently have it setup to listen for one IP 10.0.0.10. How would I setup it up to listen on all 3? Do I just need to define another webfarm? I have included my haproxy.cfg


Code:
 
   
global

       uid 99
       gid 99


       daemon
   defaults


       mode http

       retries 3


       option redispatch
       maxconn 10000
       contimeout 10000
       clitimeout 50000
       srvtimeout 50000

   listen webfarm 10.0.0.10:80

       mode http
       stats uri /haproxy
       balance roundrobin
       cookie webpool insert
       option  httpclose
       option forwardfor
       server WWW1 10.0.0.20:80 cookie webpool_WWW1 check port 81 
       server WWW2 10.0.0.30:80 cookie webpool_WWW2 check port 81 
       server WWW3 10.0.0.40:80 cookie webpool_WWW3 check port 81 

   listen https 10.0.0.10:443     
       balance source
       mode tcp
       server WWW1 10.0.0.20:443 check
       server WWW2 10.0.0.30:443 check
       server WWW3 10.0.0.40:443 check
Thanks in advance for your help
Reply With Quote
Sponsored Links
Reply

Bookmarks

Tags
haproxy, load-balancing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"The Perfect Server Guide" problems DamianFick Installation/Configuration 10 5th April 2012 13:34
How To Configure PureFTPd To Accept TLS Sessions On Debian Squeeze GarGamel55 HOWTO-Related Questions 11 6th August 2011 11:45
URGENT PLEASE: 3rd Time Installing and Still Have SMTP Issues with PostFix norby Server Operation 9 24th June 2011 13:58
Something blocking port 53 stigge2000 Installation/Configuration 4 5th April 2011 14:46
Postfix POP request approx 30 sec (Mozilla...) dreamed Server Operation 3 16th February 2006 00:03


All times are GMT +2. The time now is 04:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.