#1  
Old 17th June 2013, 08:32
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,149
Thanks: 4
Thanked 56 Times in 52 Posts
Default Cron problems

Hi there

I setup a few cronjob, e.g.:

one is like that:

Code:
/var/www/clients/client1/web9/web/urteile/cron.sh
and the resulting file in /etc/cron.d looks like this:
Code:
cat ispc_chrooted_web9                                                                                                                                                                                                                              
MAILTO=''                                                                                                                                                                                                                                                                      
                                                                                                                                                                                                                                                                               
#SHELL='/usr/sbin/jk_chrootsh'                                                                                                                                                                                                                                                 
                                                                                                                                                                                                                                                                               
10      12,13   *       *       *       web9    /var/www/clients/client1/web9/web/urteile/cron.sh       #regenmacher.ch

However a new one I created looks like this:
Code:
/var/www/clients/client1/web41/web/sr_orig/cron.sh  2>&1 | mail -s "SR Cron" 'user@domain.com'
but the entry in cron.d looks like that:
Code:
cat ispc_chrooted_web41 
MAILTO=''                                                                                                                                                                                                                                                                      
SHELL='/usr/sbin/jk_chrootsh'                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                               
30      7       *       *       *       web41   /web/sr_orig/cron.sh  2>&1 | mail -s "SR Cron" 'user@domain.com' #sub.domain.com
For some reason the web41 is chrooted but I don't recall having set chrooting up for it.
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
The Following User Says Thank You to sjau For This Useful Post:
adamassasda291 (22nd June 2013)
Sponsored Links
  #2  
Old 17th June 2013, 09:11
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,149
Thanks: 4
Thanked 56 Times in 52 Posts
 
Default

fixed it
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cron problems and server stuck K_meleonu Server Operation 1 14th September 2012 22:13
Problems(?) regarding chrooted cron jobs Croydon Installation/Configuration 2 12th July 2012 18:29
A lot of problems again (cron, log, spam) adam_clayton Installation/Configuration 3 7th May 2011 14:00
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 10:11
CRON and .htaccess problems devilslayer General 1 23rd November 2007 17:49


All times are GMT +2. The time now is 08:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.