Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > ISPConfig 3 Priority Support

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 14th June 2013, 10:21
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Tried just using the IP address of my server, still no luck. Same error message.
__________________
Regards,
Steven Swarts
Reply With Quote
Sponsored Links
  #12  
Old 14th June 2013, 10:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

Ok, so there must be something wrong with the horde code or rewrites rules, especially as this happens only on this one URL. If it would be a general rewrite issue e.g. caused by ispconfig, then no URLS in the /horde directory would work as ispconfig is not applying any rules specific to horde or one of its subdirectories.

It seems as if horde tries to rewrite to a file /var/www/horde/nag/t on the disk instead of https://cleandrum.com/horde/nag/t which then gets rewritten to a php file. You should check the .htaccess file in /var/www/horde with the horde devs, maybe there is an option that needs to be activated or the URL is rewritten in the wrong way inside that file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 14th June 2013, 10:38
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
Ok, so there must be something wrong with the horde code or rewrites rules, especially as this happens only on this one URL.
Just to clarify - This error happens on ALL the websites and the IP, there is no difference. So that would seem to suggest that either mod_rewrite is not configured properly or I have issues with some code somewhere??

Correct?

The Horde Dev team no longer reply to this problem. Seems its too hard for them, or I'm too dumb.
__________________
Regards,
Steven Swarts
Reply With Quote
  #14  
Old 14th June 2013, 10:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

Quote:
Just to clarify - This error happens on ALL the websites and the IP, there is no difference.
Correct, and this shows us that its a horde issue and not one inside the sjwarts website created by ispconfig. In my post above I referred to the URL inside of horde and not the domain you access horde with. If it would be a general rewrite issue e.g. as if mod_rewrite is not active like the horde devs told you, then nothing in horde would work, not even the horde login. But your problem is just a single function in horde is not working, if I understood you correctly, its just that the task manager does not work and that indicates that something in horde or in a .htaccess file in the horde install folder handles this taskmanager URL differently then the other functions in horde.

Please post the .htaccess file from horde, maybe we find something in there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #15  
Old 14th June 2013, 10:53
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
Please post the .htaccess file from horde, maybe we find something in there.
Code:
# IMPORTANT: DO NOT EDIT THIS FILE!
# It will be overwritten with any future upgrade.

allow from all

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond   %{REQUEST_FILENAME}  !-d
    RewriteCond   %{REQUEST_FILENAME}  !-f
    RewriteRule ^(.*)$ rampage.php [QSA,L]
</IfModule>
__________________
Regards,
Steven Swarts
Reply With Quote
  #16  
Old 14th June 2013, 10:55
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

It seems that I have broken it now, nothing is logging on. I tried a different user and Horde is throwing errors that the user isn't allowed...

Code:
PHP Fatal error:  Uncaught exception 'Horde_Exception_PushApp' with message 'User user@allaboutwood.com.au is not authorized for Horde.' in /usr/share/php/Horde/Registry.php:1517\nStack trace:\n#0 /usr/share/php/Horde/Registry.php(1153): Horde_Registry->pushApp('horde', Array)\n#1 /usr/share/php/Horde/Registry.php(2089): Horde_Registry->callAppMethod('horde', 'logout')\n#2 /usr/share/php/Horde/ErrorHandler.php(35): Horde_Registry->clearAuthApp('horde')\n#3 [internal function]: Horde_ErrorHandler::fatal(Object(Horde_Exception_AuthenticationFailure))\n#4 {main}\n  thrown in /usr/share/php/Horde/Registry.php on line 1517
__________________
Regards,
Steven Swarts
Reply With Quote
  #17  
Old 14th June 2013, 13:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

Quote:
Originally Posted by sjswarts View Post
Code:
# IMPORTANT: DO NOT EDIT THIS FILE!
# It will be overwritten with any future upgrade.

allow from all

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond   %{REQUEST_FILENAME}  !-d
    RewriteCond   %{REQUEST_FILENAME}  !-f
    RewriteRule ^(.*)$ rampage.php [QSA,L]
</IfModule>
Please try to remove the following lines:

<IfModule mod_rewrite.c>

and

</IfModule>

If mod_rewrite would not be loaded, you will get a apache 500 error then.

Regarding the login error, do you remember what you changed since you logged in successfully the last time?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 15th June 2013, 10:20
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Like this?

# IMPORTANT: DO NOT EDIT THIS FILE!
# It will be overwritten with any future upgrade.

Code:
allow from all

#<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond   %{REQUEST_FILENAME}  !-d
    RewriteCond   %{REQUEST_FILENAME}  !-f
    RewriteRule ^(.*)$ rampage.php [QSA,L]
#</IfModule>
If so then it still errors
__________________
Regards,
Steven Swarts

Last edited by sjswarts; 15th June 2013 at 10:20. Reason: syntax
Reply With Quote
  #19  
Old 15th June 2013, 10:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

Ok, if the error is still the same, then the problem is not that mod_rewrite is inactive like the horde devs said. Otherwise you would get an apache error (most likely 500) that the directive RewriteEngine is invalid.

Do you remenmber what you did in the horde install which might have caused the "User user@allaboutwood.com.au is not authorized for Horde." error? I guess this must be something in the horde user config or changing of a databse login or similar and not a change in a apache file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #20  
Old 15th June 2013, 10:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
 
Default

And which guide did you follow to install horde on your server? Here is e.g. a guide for horde 4 on a ispconfig server, maybe you can compare your configuration steps with that guide even if you use a newer horde version:

http://www.howtoforge.com/install-ho...e-through-pear
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
apache, error, horde, ispconfig, nag

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
vhost.conf.master does not generate any virtual host ollea Installation/Configuration 24 23rd April 2012 14:12
All files gone after changing quota to 0 spynode General 17 19th January 2012 14:41
ISPConfig 3.0.0.8 RC1 released till General 92 22nd February 2010 09:52
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
CentOS 5.1 Server Setup: LAMP, Email, DNS, FTP, ISPConfig (a.k.a. The Perfect Server) Derekman9 HOWTO-Related Questions 1 15th October 2008 13:35


All times are GMT +2. The time now is 07:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.