Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th May 2013, 21:49
labsy labsy is offline
Junior Member
 
Join Date: Apr 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Default web page on server's IP address

Hi,

As I remember running ISPConfig for last 2 years, my server by default when typing http://1.2.3.4 (public IP of server) returned some default web page, telling there's nothing here.

But now, all of the sudden (maybe after upgrading to ISPConfig 3.0.5.2 or after adding another public IP address...I don't know) my server returns this content under http://1.2.3.4:

/var/www/clients/client8/web94

Any idea why?
How did it get set to site ID 94? It is nothing special wit this web site, not the first, not last web site. There are web site IDs from 1 to 200, why 94?
Also client 8 is nothing special, no special features. It's just one of the many.
...hmmmm...the only corelation to web site ID 94 I see is that the DOMAIN of this web ID is the first on the top by alphabet, so it is also the first symlink in /var/www/ directory. Might it be because of that returning this site as default?


And how to reset it back to default?

Last edited by labsy; 27th May 2013 at 22:08.
Reply With Quote
Sponsored Links
  #2  
Old 27th May 2013, 22:23
labsy labsy is offline
Junior Member
 
Join Date: Apr 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

SOLVED!
ISPConfig, or better, Apache, shows the first site by alphabetical order if no default site is set. So the solution is to create a web site to be on the top by alphabetical order, regardless the name, for example:

000000-default.com

Put the index.html there and it will be shown if user types in IP address of the server.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
ERROR: unable to bind listening socket for address '127.0.0.1:8999': Address already kvess1967 HOWTO-Related Questions 1 8th March 2013 14:49
Server hangs, BUG: Bad page state in process lucani Installation/Configuration 1 6th September 2012 18:50
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 14:51
amavis: (!!)WARN: all primary virus scanners failed, considering ba jariasca Installation/Configuration 13 20th April 2010 17:34


All times are GMT +2. The time now is 14:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.