Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 25th May 2013, 12:14
realtebo realtebo is offline
Junior Member
 
Join Date: May 2013
Posts: 22
Thanks: 7
Thanked 1 Time in 1 Post
Unhappy mail_user_add not working

I'd like to share with you this piece of my log file.

I'm doing something wrong with mail_user_add function. Because it give me 3 errors



Code:
2013/05/25 11:08:54 [trace] [ispconfigsoap] updateMailConfig - Cliente #62: gatto.pardo@libero.it - alepado
2013/05/25 11:08:55 [trace] [ispconfigsoap] Logged successfull. Session ID:a10efcc3f995bc89068db6b5687ea451
2013/05/25 11:08:55 [trace] [ispconfigsoap] array
(
    'server_id' => 1
    'email' => 'gatto.pardo-libero.it@smsdevmirko.ispeed.local'
    'login' => 'gatto.pardo-libero.it@smsdevmirko.ispeed.local'
    'password' => 'alepado'
    'name' => 'gatto pardo (test59)'
    'uid' => 5000
    'gid' => 5000
    'maildir' => '/data/var/vmail/smsdevmirko.ispeed.local/gatto.pardo-libero.it'
    'quota' => 0
    'cc' => ''
    'homedir' => '/data/var/vmail'
    'autoresponder' => 'n'
    'autoresponder_start_date' => ''
    'autoresponder_end_date' => ''
    'autoresponder_text' => ''
    'move_junk' => 'y'
    'custom_mailfilter' => ''
    'access' => 'n'
    'disabledeliver' => 'n'
    'disablesmtp' => 'n'
    'postfix' => 'y'
    'disableimap' => 'y'
    'disablepop3' => 'y'
)
2013/05/25 11:08:55 [trace] [ispconfigsoap] Exception in updateMailConfig per gatto.pardo@libero.it:
quota_size_error_empty<br />
quota_size_error_regex<br />
directory_error_empty<br />
I know it's strange to create mailbox with this kind of username, but it's necessary for our internal needs, and please keep in mind that when I tried to modify mail_user_add.php into examples dir of installation file and run it with php -f mail_user_add.php using the same parameters everything worked

Code:
root@vldidevhost1:~/ispconfig3_install/remoting_client/examples# php -f mail_user_add.php

Logged successfull. Session ID:0f046f41dba366a39bf6ad79a1458e12
New user: 13
Logged out.<br />
The same code, with same parameters created a new user with is 13, but when it run from my code it give me 100% of times the error pasted at the top.

Why ? What could be the problem ? Why the same api with the same parameters do different things ?!

Last edited by realtebo; 25th May 2013 at 12:22.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
please help me urgently, Iím trying to configure my own web server, I want to have t mahmodsob Server Operation 6 20th September 2012 13:04
my site not working busykid Installation/Configuration 1 27th September 2011 11:55
my site not working busykid Installation/Configuration 1 26th September 2011 21:39
Qemu-kVM setup vm using 2 NIC's are not working muzi Technical 1 14th February 2011 23:27
auto update svn working copy donix Installation/Configuration 0 9th June 2010 21:59


All times are GMT +2. The time now is 08:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.