Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 23rd May 2013, 20:28
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 387
Thanks: 28
Thanked 58 Times in 50 Posts
Default Force disconnect instead of 554 5.7.1 <user@example.com> Relay access denied

I am using Postfix and have noticed vast numbers of messages like this one lately:

Code:
postfix/smtpd[20961]: NOQUEUE: reject: RCPT from some-host.example.com[1.2.3.4]: 554 5.7.1 <user@domain2.com>: Relay access denied; from=<user@domain1.com> to=<user@domain2> proto=ESMTP helo=<[169.254.97.163]>
This results from automated "bots" attempting to hammer mail through this server (even though relaying is not allowed).

I find this annoying. Is there some way to drop the connection immediately if the user-agent has not authenticated? I don't want anybody sending mail through this server who isn't authenticated, unless the connection is coming from 127.0.0.1. Everyone else can simply be disconnected immediately.

This must be possible in Postfix. Any help is greatly appreciated.

P.S. Yes, I have searched on this subject, but, unfortunately, almost all of the resources returned relate to people who are receiving "relay access denied" erroneously when trying to send legitimate mail themselves.
Reply With Quote
The Following User Says Thank You to cbj4074 For This Useful Post:
bamlesqtivanova6307 (28th May 2013)
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 won't start after update Cracklefish Installation/Configuration 15 28th February 2012 14:11
Postfix doesn't have Nolan Installation/Configuration 5 13th April 2011 05:00
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26


All times are GMT +2. The time now is 11:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.